X Server 1.20.4 is freezing after first Linux boot of the day on my Geforce GTX770

Hi guys!

I’m struggle now for weeks with the issue that my X Server is freezing after the first boot of the day. The freeze is not immediately after the login but different minutes after - it’s random. When I restart my system on this point I don’t get any freezes anymore on this day. I already tried some driver versions also a re-installation of Linux but nothing worked. It also happens when I do nothing, so while idling.

Here some Systeminfos:

Mainboard: ASRock Z77 Pro4
CPU: Intel Core i5-3570
RAM: 4x4GB Kingston HyperX DDR3-SDRAM
GPU: MSI Geforce GTX770 TwinFrozr II
SFX: Creative SoundBlaster X-Fi Fatal1ty Titanium
SSD: 2xSamsung SSD 850 Evo 250MB, 1xSamsung SSD 840 128GB
Perph.: Dell USB Keyboard, Logitech G502 Proteus Spectrum, Microsoft Xbox360 Wireless Controller Dongle

OS: Ubuntu Linux 18.04LTS
Driver: 430.50 from a PPA but it makes no difference if I use a driver from a public PPA, from the Cannonical repository or directly from Nvidia
Apps in the BG: Teamspeak 3, Telegram, Signal, Variety, Steam, SeaDrive
In autostart: TS3, Telegram, Signal, Variety, Steam, SeaDrive, Nvidia X Server thing, eMail reminder
Btw.: I’m using Lutris and additional Vulkan drivers.

You can download my Nvidia Bug Report Log here from my private cloud: https://cloud.jotoma.de/f/d5c82b8077524d4a9fc0/

In the past I never had such issues on Windows.

If I forgot some infos so please tell me. :)

You’re running into an XID 79 which is hardware related. You should first look for a bios update, if this doesn’t help, this points to a failing psu or gpu. Since this is only happening on first boot, might be a thermal fault so something needs to heat up to work reliably.

Hi generix!

Hmm… yes there is a Bios Update for my Mainboard. I already updated 1 or 2 weeks ago but falled back to the current (older version from 2013) because the new from 2018 didn’t recognize my Ubuntu EFI Boot anymore. But on this time I had still Windows 10 installed on my “main” SSD and Ubuntu on my third SSD (840). I will try it again but I think it will fail again. It’s just a beta Bios. (http://asrock.com/MB/Intel/Z77%20Pro4/index.asp#BIOS)

Failing GPU or PSU… I don’t know if it’s really is because I had no issue on Windows. But there was a time also my Windows freezes. After a complete un- and re-installation that issue was gone but I also did it on Linux and nothing changed. Maybe it’s the Mainboard? In worst case I got also a Z77 Pro3. Btw. I also tried the X.org Nouveau driver and the same issue. So maybe you’re right. Maybe it’s the PSU because I couldn’t use the second PCI-Express connector so I had to use a adapter (PCI-E to SATA). Maybe this bus rail is faulty? But I think this rail does have enough power. Actually beQuiet! PSU are very good PSU’s and I configured my system the capacitors lasting a long time.

I have to investigate more. But thank you for your hint that helps me a lot!

XID 79 is hardware, so reinstalling driver/OS doesn’t help. Rather concentrate on that, sometimes reseating connectors/cards helps.