Xavier AGX - No CUDA Tooklit installed - errors trying to install

I just got my Xavier and I am anxious to use it, but unfortunately it doesn’t have CUDA 10.2 installed like it is on the fresh install on the Nanos I have. I finally found a repo for ARM64 ubuntu and try to install. It gets the errors below. Any help is appreciated. I cannot use the SDK manager as there is not an ARM64 version. How do I update Jetpack and all of the software?

Get:1 file:/var/cuda-repo-10-2-local-10.2.107-435.17.01 libnvidia-compute-435 435.17.01-0ubuntu1 [8,141 kB]
Get:2 file:/var/cuda-repo-10-2-local-10.2.107-435.17.01 libnvidia-gl-435 435.17.01-0ubuntu1 [21.8 MB]
debconf: delaying package configuration, since apt-utils is not installed
(Reading database … 160234 files and directories currently installed.)
Preparing to unpack …/libnvidia-compute-435_435.17.01-0ubuntu1_arm64.deb …
Unpacking libnvidia-compute-435:arm64 (435.17.01-0ubuntu1) …
dpkg: error processing archive /var/cuda-repo-10-2-local-10.2.107-435.17.01/./libnvidia-compute-435_435.17.01-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/lib/aarch64-linux-gnu/libcuda.so’, which is also in package nvidia-l4t-cuda 32.3.1-20191216133751
Preparing to unpack …/libnvidia-gl-435_435.17.01-0ubuntu1_arm64.deb …
Unpacking libnvidia-gl-435:arm64 (435.17.01-0ubuntu1) …
dpkg: error processing archive /var/cuda-repo-10-2-local-10.2.107-435.17.01/./libnvidia-gl-435_435.17.01-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/share/glvnd/egl_vendor.d/10_nvidia.json’, which is also in package nvidia-l4t-3d-core 32.3.1-20191216133751
Errors were encountered while processing:
/var/cuda-repo-10-2-local-10.2.107-435.17.01/./libnvidia-compute-435_435.17.01-0ubuntu1_arm64.deb
/var/cuda-repo-10-2-local-10.2.107-435.17.01/./libnvidia-gl-435_435.17.01-0ubuntu1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

1 Like

I have same problem!!!