Xavier Fails to Flash

I’ve been trying to get my Xavier started. Always fails right when it says “press enter” before flashing in the terminal.

  • lsusb shows nvidia is connected 0955:7019

The one thing I notice is that after doing the compilation side there is no .flash or apply_binaries .sh scripts in linux_for_tegra folder.

See my below log file output.

Thanks!


FLASH_OS_GALEN.LOG OUTPUT >>

/bin/bash: ./flash.sh: No such file or directory


FILESYSTEM_GALEN.log OUTPUT >>

/bin/bash: line 0: cd: /home/phillip/Downloads/Xavier/Linux_for_Tegra/rootfs/: No such file or directory
/bin/bash: ./apply_binaries.sh: No such file or directory


INSTALL_PYTHON.log OUTPUT >>

Get:1 file:/var/cuda-repo-10-0-local-10.0.166-410.62 InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.166-410.62 InRelease
Get:2 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 InRelease
Ign:2 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 InRelease
Get:3 file:/var/visionworks-repo InRelease
Ign:3 file:/var/visionworks-repo InRelease
Get:4 file:/var/visionworks-sfm-repo InRelease
Ign:4 file:/var/visionworks-sfm-repo InRelease
Get:5 file:/var/visionworks-tracking-repo InRelease
Ign:5 file:/var/visionworks-tracking-repo InRelease
Get:6 file:/var/cuda-repo-10-0-local-10.0.166-410.62 Release [574 B]
Get:7 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 Release [574 B]
Get:8 file:/var/visionworks-repo Release [1,999 B]
Get:9 file:/var/visionworks-sfm-repo Release [2,003 B]
Get:6 file:/var/cuda-repo-10-0-local-10.0.166-410.62 Release [574 B]
Get:10 file:/var/visionworks-tracking-repo Release [2,008 B]
Get:7 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 Release [574 B]
Get:8 file:/var/visionworks-repo Release [1,999 B]
Get:9 file:/var/visionworks-sfm-repo Release [2,003 B]
Get:10 file:/var/visionworks-tracking-repo Release [2,008 B]
Hit:16 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Get:17 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:19 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Fetched 252 kB in 1s (263 kB/s)
Reading package lists…

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists…
Building dependency tree…
Reading state information…
The following additional packages will be installed:
libpython-stdlib python-minimal python2.7 python2.7-minimal
Suggested packages:
python-doc python-tk python2.7-doc binfmt-support
The following NEW packages will be installed:
libpython-stdlib python python-minimal python2.7 python2.7-minimal
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 176 kB/1,709 kB of archives.
After this operation, 4,978 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 python-minimal amd64 2.7.15~rc1-1 [28.1 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 libpython-stdlib amd64 2.7.15~rc1-1 [7,620 B]
Get:3 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 python amd64 2.7.15~rc1-1 [140 kB]
dpkg-preconfigure: unable to re-open stdin: No such file or directory
Fetched 176 kB in 1s (325 kB/s)
Selecting previously unselected package python2.7-minimal.
(Reading database …
(Reading database … 5%
(Reading database … 10%
(Reading database … 15%
(Reading database … 20%
(Reading database … 25%
(Reading database … 30%
(Reading database … 35%
(Reading database … 40%
(Reading database … 45%
(Reading database … 50%
(Reading database … 55%
(Reading database … 60%
(Reading database … 65%
(Reading database … 70%
(Reading database … 75%
(Reading database … 80%
(Reading database … 85%
(Reading database … 90%
(Reading database … 95%
(Reading database … 100%
(Reading database … 199562 files and directories currently installed.)
Preparing to unpack …/python2.7-minimal_2.7.15-4ubuntu4~18.04_amd64.deb …
Unpacking python2.7-minimal (2.7.15-4ubuntu4~18.04) …
Selecting previously unselected package python-minimal.
Preparing to unpack …/python-minimal_2.7.15~rc1-1_amd64.deb …
Unpacking python-minimal (2.7.15~rc1-1) …
Selecting previously unselected package python2.7.
Preparing to unpack …/python2.7_2.7.15-4ubuntu4~18.04_amd64.deb …
Unpacking python2.7 (2.7.15-4ubuntu4~18.04) …
Selecting previously unselected package libpython-stdlib:amd64.
Preparing to unpack …/libpython-stdlib_2.7.15~rc1-1_amd64.deb …
Unpacking libpython-stdlib:amd64 (2.7.15~rc1-1) …
Setting up python2.7-minimal (2.7.15-4ubuntu4~18.04) …
Linking and byte-compiling packages for runtime python2.7…
Setting up python-minimal (2.7.15~rc1-1) …
Selecting previously unselected package python.
(Reading database …
(Reading database … 5%
(Reading database … 10%
(Reading database … 15%
(Reading database … 20%
(Reading database … 25%
(Reading database … 30%
(Reading database … 35%
(Reading database … 40%
(Reading database … 45%
(Reading database … 50%
(Reading database … 55%
(Reading database … 60%
(Reading database … 65%
(Reading database … 70%
(Reading database … 75%
(Reading database … 80%
(Reading database … 85%
(Reading database … 90%
(Reading database … 95%
(Reading database … 100%
(Reading database … 199619 files and directories currently installed.)
Preparing to unpack …/python_2.7.15~rc1-1_amd64.deb …
Unpacking python (2.7.15~rc1-1) …
Processing triggers for mime-support (3.60ubuntu1) …
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) …
Setting up python2.7 (2.7.15-4ubuntu4~18.04) …
Setting up libpython-stdlib:amd64 (2.7.15~rc1-1) …
Processing triggers for man-db (2.8.3-2ubuntu0.1) …
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) …
Setting up python (2.7.15~rc1-1) …

Hi sky_walker,

Are you using SDKManager to install Xavier?
or using manually steps to flash Xavier?
Suggest you can download and try again.

● SDKManager: https://developer.nvidia.com/embedded/dlc/nv-sdk-manager
● Flash by manually:

Yes, using the SDKManager. I’ve done the .run way too.

Further output from SDK Manager:
Drivers for Jetson AGX: tar: Unexpected EOF in archive
Drivers for Jetson AGX: tar: Error is not recoverable: exiting now
Drivers for Jetson AGX: NV_L4T_DRIVERS_XAVIER_COMP command /tmp/tmp_NV_L4T_DRIVERS_XAVIR_COMP.sh finished with error

Unavailable components detected, please check log
File system and OS skipped. Due to its dependencies fail to install: Drivers for Hetson AGX.
Flash skipped due to component(s) download/install failure

This repeats like… 10 more times in a row

Hi, I have the same problem.

I’ve tried both SDKManager and JetPack4.1.1(L4T 31.1).

and neither of them didn’t work. it returns the same error message just like you.

Hi sky_walker,

Please check this topic:
https://devtalk.nvidia.com/default/topic/1056381

This worked great.

Thanks!