Xavier industrial after startup, the typeA usb interface power down

Hi,
A type A usb port on the customized board is powered off after the system starts. Previously this interface was available. In addition, spi2 interface does not generate SPI nodes .After the system startup, in the/sys/firmware/devicetree/base/spi @ c260000 status is okay. All functions are normal on 32GB xavier . I check syslog and find “nv_update_engine Fail to open metadata file” Does that have anything to do with it? I looked at the difference between Xavier and xavier Industrical and found no difference on USB and SPI.
Could you help me find out what the problem is.
nvidia-bug-report-tegra.log (697.6 KB)

What do you mean "Previously this interface was available. "? This error happens suddenly? or something else?

How many usb port are on your custom board? Board schematic to share?

"Previously this interface was available. " It refers to the period from the system startup to dispaly the login screen.the mouse is available. then the USB port is suddenly powered off.The same thing happens every time start.
There are four USB ports on our carrier board, and other ports can be used normally. The faulty USB port is directly connected to the SOC.

Is that usb port working fine if it is on devkit?

I didn’t use it on the devkit, but the custom board works fine on Xavier Module 2888-0001 L4T32.5.0

Did you make any change on your Xavier p2888 module to let this work on the custom board? For example, the device tree change.

I changed the device tree for Xavier P2888 and made the same changes for Xavier Industrial.

How many hub is connected on your board?

Can you directly give an overall usb status of each pin so that we can understand your case easily?

I don’t see usb error from your dmesg.




gpio@c2f0000 {
usbP9-0-reg-enable {
gpio-hog;
output-high;
gpios = <TEGRA194_AON_GPIO(AA, 5) 0>;
label = “usbP9-0”;
status = “okay”;
};
}

fixed-regulator dtsi
rtso1001_p9_0_5v0: regulator@115 {
compatible = “regulator-fixed”;
reg = <115>;
regulator-name = “usb-p9-0-5v0”;
regulator-min-microvolt = <5000000>;
regulator-max-microvolt = <5000000>;
gpio = <&tegra_aon_gpio TEGRA194_AON_GPIO(AA, 5) 0>;
enable-active-high;
vin-supply = <&battery_reg>;
};

A 4P hub is inserted into the carrier board,
Can we see what the problem is from the above?

I don’t think you need to write a usbP9-0-reg-enable here. Just give the rtso1001_p9_0_5v0 regulator to the vbus. Please refer to the adaptation guide for usb porting.

Hi,
I comment out usbP9-0-reg-enable,then update the DTB file, and the problem is the same as before.

What kind of usb device are in use now? Can you try different usb devices and see if any error from dmesg?

As my previous comment said there is no error from the dmesg.

Hi,
Now I only have a USB wireless mouse and a USB storage device on my device . Attached is the log of this time. Help me see if can find the problem.
nvidia-bug-report-tegra.log (578.1 KB)

I still cannot find out what kind of problem you have here.

The USB wireless is getting detected.

nvidia-desktop kernel: input: MOSART Semi. Mi Wireless Combo as /devices/3610000.xhci/usb1/1-2/1-2:1.0/0003:2717:5010.0001/input/input4

Do you connect this on the problematic port or you connect on another hub? Please do not put usb device to unnecessary port.

When the device start , I was connecting the USB wireless mouse to problematic port,When this USB port power off, I connect the mouse into another USB port .After that, I connect a USB storage device into another USB port to save the log.

Just connect it to the problematic usb port and share me the whole dmesg. That’s all you need to do.

Do not connect any other device anymore.

Also, I don’t need nvidia-bug-report-tegra.log. Just dmesg and lsusb are sufficient.

The attached log is connected to a mouse on the problematic USB port. demsg.txt (75.8 KB)
lsusb.txt (252 Bytes)
lsusb-t.txt (275 Bytes)

Hi,

The weird thing is I still see your wireless mouse gets detected in the beginning.

[ 2.253542] usb 1-2: new full-speed USB device number 2 using tegra-xusb
[ 2.275995] usb 1-2: New USB device found, idVendor=2717, idProduct=5010
[ 2.276003] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2.276008] usb 1-2: Product: Mi Wireless Combo
[ 2.276013] usb 1-2: Manufacturer: MOSART Semi.
[ 2.278039] input: MOSART Semi. Mi Wireless Combo as /devices/3610000.xhci/usb1/1-2/1-2:1.0/0003:2717:5010.0001/input/input4
[ 2.337968] hid-generic 0003:2717:5010.0001: input,hidraw0: USB HID v1.10 Keyboard [MOSART Semi. Mi Wireless Combo] on usb-3610000.xhci-2/input0
[ 2.340635] input: MOSART Semi. Mi Wireless Combo as /devices/3610000.xhci/usb1/1-2/1-2:1.1/0003:2717:5010.0002/input/input5
[ 2.397890] hid-generic 0003:2717:5010.0002: input,hidraw1: USB HID v1.10 Mouse [MOSART Semi. Mi Wireless Combo] on usb-3610000.xhci-2/input1

Also, do you really give the usb-p9-0-5v0 to the vbus-supply of your usb port? I see the log says it is getting disabled.

Which means no one is using this regulator.

[ 42.337881] usb-p9-0-5v0: disabling

The system start to dispaly the login screen, problematic USB port was available, but then it was unavailable .
“wireless mouse gets detected in the beginning”. Is that the reason?
usb-p9-0-5v0 has been used in devicetree