XAVIER NX DevKit boots but no display on Serial or Monitor

I have a NX DevKit and when I boot it using the micro USB, there is no output. Initially I thought it might be my monitor, but then I tried the display on both HDMI and Display port but no luck. I tried the display port on my laptop and it worked, so the monitor isn’t an issue.

I reflashed the microSD card thinking it might the o/s but still no luck. Based on the user guide, J14 pins 3/4/7 are UART and I tried connecting them and used minicom to see the serial output and no luck.

The green LED is on, so I know it is being powered on.

Any suggestions as to what else am I missing??

Thanks!

  1. You can try to use sdkmanager to flash your board first

  2. I doubt if the connection and setup of uart is correct here. Please check below tutorial.
    Jetson Nano - Serial Console - JetsonHacks

Hi @WayneWWW
I had the green and the white wired crossed. I used the link you have and then gte the following UART output:
[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-80a468da)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0xe11f7
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.265] Non secure mode, and RB not enabled.
[0000.269] Read GPT from (4:0)
[0000.361] Csd NumOfBlocks=121503744
[0000.366] Set High speed to 1
[0000.369] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWai
[0000.379] Command complete wait failed with error 0x3 Interrupt 0x18001
[0000.385] Number of retries left 4
[0000.395] Using GPT Primary to query partitions
[0000.400] Read PT from (2:0)
[0000.415] Using BFS PT to query partitions
[0000.419] PT: Partition TBC NOT found !
[0000.423] Warning: Find Partition via PT Failed
[0000.427] failed to load NvTbootTbootCpu from (4:0)
[0000.432] re-load NvTbootTbootCpu from (2:0)
[0000.437] PT: Partition TBC NOT found !
[0000.440] Warning: Find Partition via PT Failed
[0000.445] PT: Partition TBC NOT found !
[0000.449] Warning: Find Partition via PT Failed
[0000.453] Error is 1

I reformatted the micro-sd card and flashed with jetpack 4.4 and still get the same error. I dont have the power barrel adapter so this was with micro-usb port to boot.

Thanks!

Hi,

Could you directly use sdkmanager with jetpack4.5.1?

Also, when you said flashed with jetpack4.4, are you also using sdkmanager? or sdcard image?

@WayneWWW - I’m using SD Card Image Since I don’t have the power barrel power adapter, I’m using the micro-usb to boot… So, I don’t think I flash using the SDK Manager.
I was using JetPack 4.4 as JetPack 4.5.1 is not supported on Aetina AN810 Carrier Board so I’m trying to do my development on the same jetpack as production board.

I think the only way to resolve this issue seems the sdkmanager.

Does this board ever work before? Also, if you are using Aetina board, why tell us you are using devkit in the beginning?

@WayneWWW - No, this is the devkit which is not displaying anything. This board was working before. I had it shut down for a while to test something else and now when I go back to plug it in and use it, it didn’t work and did not display anything. I took the SD Card out and used sdcard formatter to format and then use balena etcher to image the JetPack 4.4.

Aetina is for production use, but for development I’m using the devkit. I brought Aetina up as you were saying using JetPack 4.5.1 and I indicated it will not be compatible with my production board so for devkit I want to use JetPack4.4

Ok, then do not use Anteina board now. We only focus on the devkit issue.

Please try to get a power jack and use sdkmanager. The qspi on board will not be updated if you only update sdcard with 4.4 image. Only the sdkmanager will update them.

@WayneWWW - I was trying to flash the nano devkit instead of the nx devkit. I imaged the sd card with the nano jetpack image and it booted fine. Is there a way to tell the difference between nx devkit and nano devkit??

Thank you so much for your time. I feel embarrassed, should have labelled them correctly.

Hi,

To prevent confusion, could you tell me what is the exact module/carrier board you have there?

When you say “nano devkit”, do you mean nano module + nano carrier board or only the nano carrier board?

@WayneWWW - its a nano module and nano carrier board.
For production use, we are ordering the carrier boards from aetina and using nx production module

I have moved this topic to nano forum… If I understand your comment correctly, your nano module is able to boot up fine on nano devkit but it has problem when same sdcard + module is on NX devkit…?

Please correct me if I am wrong here. I really don’t know which module has problem. Honestly, you don’t need to mention something that is not in use. For example, I don’t get why Aetina board is mentioned here. It is for production… and does it has anything to do with current issue?

@WayneWWW - I believe we can close this case. My apologies for the confusion.
Initially I had the nx devkit but I gave that to another colleague and I replaced that with the Nano Devkit. So, when I was trying to reflash SD card, I was using nxdevkit image and not nano devkit. After I flashed the SD card with nano devkit, I am all good.

1 Like

It is okay. If you still have something wrong with nano module +nx carrier, you could check if your nano module is A02 or B01 sku, it should be labeled on the module itself. Only B01 module is able to work with nx carrier board.