Xcode built iOS Sample error

Hi everone

when I built iOS sample, Xcode always error to build by “Library not found for ~lCloudXR”.
how do I solve this?


Same issue.
I want to try build client on CloudXR 2.1 but download archive not found.
Where is a lCloudXR?

1 Like

I found a solution.

  1. Create “lib” folder on Sample/iOS
  2. Copy files to Sample/iOS/lib from Client/Lib/iOS/

After that, solved this problem.
However, I got another error.

Build input file cannot be found: ‘…/CloudXR/11-12-2021-CloudXR-SDK/Sample/iOS/CloudXRClientObjC/CloudXRClientObjC/Base.lproj/Main.storyboard’

I can’t found storyboard files. so I solved this by below steps.

  1. Open Sample/iOS/CloudXRClientObjC/CloudXRClientObjC/Base.lproj/
  2. Clone 2 xml files.
  3. Rename cloned files to .storyboard from .storyboard.xml
  4. Open tab “BuildPhases” on XCode.
  5. Unlink(-) “LaunchScreen.storyboard” and “Main.storyboard”
  6. Link(+) cloned storyboards

Finally, success build and connect CloudXR!
Feel free to suggest other solutions. (I’m new to XCode)

However, the app seems not working correctly (the problem will be another topic)

1 Like

Copying the library from “Client/Lib/iOS” to “Sample/iOS/lib” or updating the Xcode project to add “Client/Lib/iOS” as a linker library search path are both fixes for this issue. This will be improved in a future SDK drop and in the future these steps will not be necessary.

oh my god! thank you very much!