XFCE session doesn't render with "ForceCompositionPipeline = On" on Fedora 29

That’s a weird thing.

I’m running Fedora 29 64 and if I add this to my Xorg.conf

Option          "Metamodes" "HDMI-0: 1920x1080 { ForceCompositionPipeline = On }"

then my XFCE session doesn’t render/show.

On log in everything stays completely invisible as if the GPU has forgotten to render the pixels. If you kill Xorg you’ll be able to see the login screen and you’re able to login only to get nothing afterwards.

GPU: GTX 1060
OS: Fedora 29 64 + XFCE
NVIDIA drivers 410.73
Kernel: 4.18.16-300.fc29.x86_64

I’m not using compositing - just a plain old X session.

Here’s my entire nvidia.conf

Section "Device"
        Identifier      "Videocard0"
        BusID           "PCI:1:0:0"
        Driver          "nvidia"
        VendorName      "NVIDIA"
        BoardName       "NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)"
        Option          "Coolbits" "28"
        Option          "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x3; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"
#       Option          "Metamodes" "HDMI-0: 1920x1080 { ForceCompositionPipeline = On }"
        Option          "TripleBuffer" "On"
        Option          "RegistryDwords"  "RMUseSwI2c=0x01; RMI2cSpeed=100"


I have a single monitor.

This issue resembles the old one.

Hi, could you try to only comment the { ForceCompositionPipeline = On } and see what happens ? It seems like the return of this particular issue :

Yeah, they both look very similar, that’s why I posted to the old thread as well. Thank you!

Without this option everything works perfectly.