[Bug] GTX 650 - Enabling ForceCompositionPipeline in xorg.conf disallows setting RandR gamma

I added the following line to the “Screen” section in my xorg.conf to prevent screen tearing:

Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"

While this works fine it bricks setting the gamma over RandR which I use to adjust my screen temperature.
When the above option is set in the xorg.conf xrandr --output HDMI-0 --gamma 100:0:0 doesn’t change anything.

I have discovered two workarounds which illustrate that this is indeed a NVIDIA driver bug. Both

  1. unplugging & replugging the HDMI cable, and
  2. manually setting the same option using nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

suddenly apply previously attempted gamma changes and further changing it works flawlessly.

I am using Arch Linux with the latest nvidia 375.26-1, nvidia-libgl 375.26-2 and xorg-server 1.19.1-1.

lspci -k graphics card section:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GTX 650] (rev a1)
	Subsystem: ZOTAC International (MCO) Ltd. Device 2263
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia

uname -srvmo output:

Linux 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64 GNU/Linux

Please fix this bug or enlighten me what I am doing wrong.
Best regards,