XR21B1412 not working after using Jetpack 5.0.1 (L4T 32.5.1)


We tried to use a USB<->RS232 transceiver (XR21B1412) reference board and Orin AGX devkit to test the RS232 function. We found a critical issue on the native cdc_acm driver when using this transceiver:

  1. System Boot up
  2. system recognize this transceiver and pop up 4 devices (/dev/ttyACM0 ~ /dev/ttyACM3)
  3. Use lookback cable and minicom to test TX/RX
  4. TX/RX works
  5. Reopen minicom and tried to run TX/RX loopback test again
  6. TX/RX failed.

Then, I switch back to Jetpack 4.6 Xavier AGX (L4T 32.6.1), I can reopen this port (/dev/ttyACM0 ~ /dev/ttyACM3) without any problems.

In conclusion, it looks like Jetpack 5.0.1’s native cdc_acm driver has incompatible issue with this transceiver. This issue is happened at reopening the port breaks the USB function.
Has any had this issue before? Any clue to solve it ?

For confirmation, do you mean you use Jetpack 5.1(r35.2.1)? Jetpack 5.0.1 is r34.1(which is developer preview) and 5.0.2 is r35.1.


The version is r35.1 (JP5.0.2).

We have Jetpack 5.1(r35.2.1) released. You may upgrade to this release and try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.