Jetson Orin USB C Port not working


System: Jetson AGX Orin Development Kit

After running the initial setup commands

sudo apt dist-upgrade
sudo apt install nvidia-jetpack

And rebooting, I cannot use the keyboard on the front facing USB-C port (J40 on devkit), which is on the same side as the 40 pin GPIO connector. Is this expected behavior, or is something wrong?

Soln: Reflashing the device solved this issue, and the appropriate USB-C port worked as desired.

Thank you for your help,

Which platform you’re using?
Have you tried to reflash by SDK Manager?

Hello @kayccc

I followed the instructions on the “quickstart for orin”, and plugged the module in, without flashing anything. After boot, I had to follow this post:

to get access to the “nvidia-jetpack” repository. After installing, I rebooted and encountered the error of the USB-C connector J40 stopped working with my ANKER USB 3.0 extender for my Keyboard and Mouse. If I plug the USB 3.0 extender into J33, everything works as expected.

I have an 18.04.6LTS computer with Nvidia SDK Manager installed, should I flash it with the Jetpack 5.0DP OS? I read that only JetPack 5.0 is compatible with the Orin architecture.


Are you using nvidia devkit?

If so, could you share the dmesg after the error happened?

Hello @WayneWWW

Yes, I am using the Jetson AGX Orin Development Kit, bought it from Arrow! The BIOS screen shows the Nvidia Logo with the version information, and below that text saying “Warning Test Key Used”.

Running the below command for release information I get:

apt-dev-orin@aptdevorin-desktop:~/Desktop$ head -n 1 /etc/nv_tegra_release
# R34 (release), REVISION: 1.0, GCID: 30102743, BOARD: t186ref, EABI: aarch64, DATE: Wed Apr 6 19:11:41 UTC 2022 

apt-dev-orin@aptdevorin-desktop:~/Desktop$ uname -a 
Linux aptdevorin-desktop 5.10.65-tegra #1 SMP PREEMPT Wed Apr 6 11:45:49 PDT 2022 aarch64 aarch64 aarch 64 GNU/Linux

Dmesg is attached
dmesg.out (76.6 KB)


Hello @kayccc

Thanks for the suggestion to reflash. Reflashing to Jetpack 5.0DP using the SDK manager fixed my problem. USB-C J40 can now drive a USB 3.0 extender with keyboard and mouse.



Can you help clarify the log? I can still see multiple usb devices got detected from your log. Are you sure this is really the “error log” we want to check?

[    8.430379] input: PixArt Gaming Mouse as /devices/platform/3610000.xhci/usb1/1-4/1-4.3/1-4.3.3/1-4.3.3:1.0/0003:093A:2530.0001/input/input0
[    8.431443] hid-generic 0003:093A:2530.0001: input,hidraw0: USB HID v1.11 Mouse [PixArt Gaming Mouse] on usb-3610000.xhci-4.3.3/input0
[    8.512177] usb 1-4.3.4: new low-speed USB device number 6 using tegra-xusb
[    8.620364] usb 1-4.3.4: New USB device found, idVendor=0c45, idProduct=7603, bcdDevice= 1.17
[    8.620610] usb 1-4.3.4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    8.620822] usb 1-4.3.4: Product: USB Keyboard
[    8.626376] input: USB Keyboard as /devices/platform/3610000.xhci/usb1/1-4/1-4.3/1-4.3.4/1-4.3.4:1.0/0003:0C45:7603.0002/input/input1
[    8.684629] hid-generic 0003:0C45:7603.0002: input,hidraw1: USB HID v1.11 Keyboard [USB Keyboard] on usb-3610000.xhci-4.3.4/input0
[    8.691122] input: USB Keyboard Consumer Control as /devices/platform/3610000.xhci/usb1/1-4/1-4.3/1-4.3.4/1-4.3.4:1.1/0003:0C45:7603.0003/input/input2
[    8.748388] input: USB Keyboard System Control as /devices/platform/3610000.xhci/usb1/1-4/1-4.3/1-4.3.4/1-4.3.4:1.1/0003:0C45:7603.0003/input/input3
[    8.749009] input: USB Keyboard as /devices/platform/3610000.xhci/usb1/1-4/1-4.3/1-4.3.4/1-4.3.4:1.1/0003:0C45:7603.0003/input/input5
[    8.749805] hid-generic 0003:0C45:7603.0003: input,hiddev96,hidraw2: USB HID v1.11 Keyboard [USB Keyboard] on usb-3610000.xhci-4.3.4/input1

Hello @WayneWWW

That dmesg log is me connecting it to the J33 port. When I connected it into the J40 port nothing would show on dmesg. Reflashing the device fixed the issue, and everything is working as expected.

Thank you for the help,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.