Cannot Install Jetpack, Repo seemingly empty

We finally got our Orin dev kits!
I tried installing jetpack on them following the instructions in the getting started guide but it seems like the nvidia-jetpack package is not in the repository.
Looking a little deeper, it looks like there are no packages at all in the nvidia repositories, even after running apt update.
Normally, for each repo, there is several files in /var/lib/apt/lists. but the Nvidia repos only have the InRelease file and not the important Packages file.

I also did a full clean install on one of them through sdk manager and there is still no nvidia-jetpack package.
I tried running some of the docker based demos and the nvidia container runtime is missing too. seems like it didnt get installed by sdk manager.

Anyone else experiencing this? Its about as useful as a normal mini pc at the moment.

1 Like

You have two options:

  • either reflash it


  • go to /etc/apt/sources.list.d/nvidia-l4t-apt-source.list and change it to:
deb r34.1 main
deb r34.1 main

and then you have the new repo. Don’t forget to do an apt dist-upgrade afterwards.

1 Like

That was it. Seems the version of L4T shipping in sdk manager is still behind too.

I had this same issue while following the instructions at.

I also noticed that the Quick Start Guide that it comes with says to go to but that link doesn’t work.

The only other weirdness was a “W: Couldn’t identify type of root file system for fsck hook” while doing “sudo apt dist-upgrade”

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.