XXXX.exe file has stopped working?

Hey guys, I’ve a problem with debugging the executable file, it compiled well with PGI and generating exe file, but when I run it it I have this error (.exe has stopped working)[/img]

Hi A.Aburawwash,

This could be any number of things so we’ll need more information.

What compiler version, OS, and CPU are you using?
What compiler flags are you compiling with?
What language is your program written in?
Does the error only occur when you are debugging? Does it succeed otherwise?

Any additional information detailing the issue would be helpful.

  • Mat

Thank you very much for your interesting;

I’m using PGI 12.4 , OS Windows 7, CPU Intel Core i5
Flag is pgifortran
language is fortran

The error only occur when I debug the exe file on my laptop
compiling is succeeded and generated exe file.

I’ve debugged it on other two laptops and it works well.

I thought the problem is with a windows so, I recovered the system and reinstalled all softwares for GPU and the problem doesn’t fix.

The only thing I can think of is that you’re running an early version of Window 7 and your processor supports AVX instructions. Windows 7 didn’t support AVX until SP1 and any binary with AVX would immediately crash.

The solution here is to either update Win7 to SP1, or add the flag “-tp=penryn-64” to your compile flags. This will tell the compiler to target an older processor and not generate AVX.

However if this is the problem, then it would occur on all binaries you build, not just with debugging. Can you compile and run a simple program without debugging enabled?

Also, I don’t know what processor (CPU) you have. “Intel Core i5” is just a brand name and doesn’t give any specific information. Try posting the output from running the “pgcpuid” utility from a PGI cmd window to get more detail.

If the AVX issue isn’t the problem, can you please explain what you mean by stating “The error only occur when I debug the exe file on my laptop”? Does this mean that it only occurs when you’re running the code with PGI’s debugger, PGDBG? or does it occur when you run from the cmd window? Does it occur when the code is not compiled with debug (-g) enabled?

Really thank you very much for your interesting mkcolg,

The problem is solved just by updating the windows