Zed camera problem with Isaac ROS

I have some problems using ZED2i camera on VSLAM Isaac ros application.
When running ros2 launch isaac_ros_visual_slam isaac_ros_visual_slam_zed.launch.py
Error is :
Caught exception when trying to load file of format [py]: “package ‘zed_wrapper’ not found, searching: [‘/opt/ros/humble’]”
So, I try colon build the zed wrapper.
But the build is not successful.


I think the newest warp need

Prerequisites

I think that container is having ubuntu 20.04 with humble, so build is fail. May I ask what version of zed ros2 should I use for this application.

Hi @lidahua

Before following the Isaac ROS Vslam quickstart demo, have you set up your machine following the documentation Isaac ROS ZED Setup — isaac_ros_docs documentation ?

Best,
Raffaello


Yes I have set up the zed camera.
/usr/local/zed/tools/ZED_Explorer
This line is sucessfully executed. But Vslam application still not working.

Your issue looks pretty similar to this post ISAAC ROS Docker package zed_wrapper not found - #10 by jim.fabian

If following the same procedure doesn’t fix the issue, please let me know.

Best,
Raffaello

I have tried it. It is still the same. Warpper cannot be built.

It seems that you have not installed the latest version of the Stereolabs SDK 4.1, and you are using an older version. I think it is the same version that is contained in our Isaac ROS docker.

I don’t suggest updating the latest ZED SDK at this time.

All Isaac ROS packages are tested with ZED SDK 4.0.6, you can use ros_zed_wrapper release Foxy-Humble-v4.0.5


I try using this ros warpper. Which also cannot run zed vslam. I try colon build, it still has error.

When you rebuild all packages, have you cleaned the build, log, and install folders?

rm -rf build log install

need super user

May can be a cause of your not compiling