10Gb networking on Jetson TX1

I need 10Gbps networking on Jetson TX1. Has anyone tried to connect a PCI Express 10 Gigabit Ethernet Network Card (like the one in the link below) to Jetson TX1?

Probably the thing to do is find out how the card works with any standard desktop Linux PC, and then see if the drivers under a desktop compile under the ARMv8a of a JTX1.

FYI, I see more specifications here:
https://www.startech.com/Networking-IO/Adapter-Cards/10gb-pcie-nic~ST10000SPEX

Thanks for your help! I tried to install the driver on the board but I get the following error:

gcc: error: unrecognized command line option ‘-mgeneral-regs-only’

Do you think I should cross compile the driver and add it as kernel module?

Native compile is still an issue because of mixed 32-bit/64-bit tool requirements. Cross-compile may help. That error is about an architecture-dependent option, so there is a strong chance of the compiler version being at issue (that’s an aarch64 option…32-bit arm compilers would fail).

The technical support of the provider was doubtful this method would work with the original drivers.

I now have a very naive question: let’s assume I can successfully cross compile the driver and add it as a kernel module. Does this mean that the device will work?

That would depend on whether the driver code had something architecture-dependent, e.g., if they used x86_64 assembler, or if something specific to that architecture is used, then cross-compile would also require porting of the non-aarch64 code. If the code cross-compiles and can be inserted in the kernel, then odds are good that there was no such architecture-dependent code…but you’ll never really know without testing.

A big question is if the support provider provides pre-compiled binaries, or if this is open source. In the case of pre-compiled binaries only, there is basically no chance of working in a foreign architecture.