11th Gen Intel® Core™ i9-11950H + NVIDIA RTX A2000 Driver issue + Ubuntu 20.0.4

╰─❯ Sudo ubuntu-drivers devices
Place your finger on the fingerprint reader
WARNING:root:_pkg_get_support nvidia-driver-510: package has invalid Support PBheader, cannot determine support level
WARNING:root:_pkg_get_support nvidia-driver-510-server: package has invalid Support PBheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd000025B8sv0000103Csd000088CEbc03sc02i00
vendor : NVIDIA Corporation
driver : nvidia-driver-470-server - distro non-free
driver : nvidia-driver-510 - distro non-free recommended
driver : nvidia-driver-510-server - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin

╰─❯ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.


  1. I re-installed drivers multiple times. Tried 470 and 510 both are giving the same error.
  2. Installed linux-generic and linux-header
  3. Disabled secure boot from BIOS
  4. Tried more than 25+ solutions given in the various threads but not resolving the issue

Please find attached the bug report.

nvidia-bug-report.log.gz (3.8 MB)

1 Like

I have the same issue. Tried everything I’ve found, nothing is working.

1 Like

Same here. I almost spend 3 days on it. Tried everything.

This error is Xorgs log pop up:

MESA-LOADER: failed to open evdi: /usr/lib/dri/evdi_dri.so

So there is an issue with your DisplayLink device.
Search the net for the error message, might point you somewhere.
Can you try to start without?

dmesg output is unusable because overflooded with this:

Apr 5 15:21:45 mhp kernel: [15381.600259] NVRM: The NVIDIA GPU 0000:01:00.0
Apr 5 15:21:45 mhp kernel: [15381.600259] NVRM: (PCI ID: 10de:25b8) installed in this system has
Apr 5 15:21:45 mhp kernel: [15381.600259] NVRM: fallen off the bus and is not responding to commands.
Apr 5 15:21:45 mhp kernel: [15381.928407] NVRM: The NVIDIA probe routine failed for 1 device(s).

I don’t know why. The output of journalctl -b0 to the point where this message appears may give some clue.

Could you also try the liquorix ppa - to check if a newer kernel helps?

1 Like

Please check this:

@generix Thanks a lot for the link and many thanks @toni.sm for mentioning the steps in detail. You guys are awesome.

Thanks for your reply, Mart. It was an intel bug in the kernel.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.