Ubuntu not allowing me to set NVIDIA driver

Apoloigies in advance if this has already been solved. I’m using Ubuntu 19.10 I’m new to Ubuntu so I will try to be as clear as possible. I found one trail that led me to

ubuntu-drivers devices

I ran the install for this driver:

model    : TU106M [GeForce RTX 2060 Mobile]
driver   : nvidia-driver-435 - distro non-free recommended

This gave me this boot error:

iwlwifi .. :BIOS contains WGDS but no WRDS

I corrected it by going into advanced boot and using a terminal to run:

apt update
apt dist-upgrade

I was able to boot but now instead of using the Integrated Intel GPU or the NVIDIA RTX 2060 Mobile I’m using “llvmpipe (LLVM 9.0, 256 bits)”

Ideally I want a CUDA driver so I can run Deep Learning Algorithms with python.

When I searched for the llvmpipe issue I found this blog and another thread in which someone asked for this file.

file:///home/houston/nvidia-bug-report.log.gz (Attached Below)(Issues attaching try googleDrive link)


But the solution for that thread doesn’t work for me.

Can anyone assist me with this issue?
nvidia-bug-report.log.gz (89.6 KB)

Please remove the kernel parameter ‘nomodeset’ as this is killing the integrated intel graphics which is needed for proper operation since this is an Optimus notebook.

You should better install Ubuntu 18.04.3 LTS, newer versions will met dependency conflicts.

CUDA 10.2 fits best with the Nvidia-440-drivers!

Consider this: 19.10 will only be supported until july 2020

18.04 is LTS which means 5 years of suoort = = > april 2023