Unable to install NVIDIA driver on Dell G15 RTX 3060 (i7-12700H)

Hello there!

I’ve been having serious issues installing NVIDIA drivers on Ubuntu on my Dell G15 with RTX3060 & 12th gen Intel CPU. So give to you the full picture:

  • it was shipped with Windows 11, I installed Ubuntu 20.04 (not in dual boot)
  • I had big troubles in the beginning, had to try several kernel versions before being able to use it
  • it’s not my first time setting up a Ubuntu laptop with NVIDIA hardware, and usually, I go for lightdm. But this time, I wasn’t able to do so: booting with lightdm gets me to a black screen where I can move my mouse but cant login (possible via tty though). So I had to use gdm3
  • whether I’m in tty, or not, I haven’t been able to install nvidia drivers. My actual goal is to install CUDA & cuDNN, so I usually install the driver at the same time as CUDA to make sure both are compatible. But after numerous attempts, I failed. Without tty, I was getting warnings that an X server was running and my usual systemctl command didn’t change anything. So I had to go to tty, unload some modules that were strangely using “nvidia” and rerun the installation. The installation keeps failing, I’ve attached the /var/log/nvidia-installer.log
    (nvidia-installer.log (10.6 MB))

So my setup currently is:

  • Ubuntu 20.04
  • kernel: 5.18.8-051808-generic
  • using gdm3
  • Secure boot disabled

So after a lot of failed attempts, I checked this post but this is for an AMD CPU. Do you have any idea how I could get around this?

I have to admit that usually, even when it’s hard and it takes a few weeks to identify where the problem comes from, I manage to finish the setup. But here, I’m running a bit out of ideas, and I bought the laptop mostly for the GPU & CPU while I cannot access the GPU here. Any help would be greatly appreciated!

In case that could be useful, I’ve attached also the nvidia-bug-report.sh output file
nvidia-bug-report.log (10.8 MB)

Cheers!

You’re missing the firmware for the intel gpu, furthermore the nvidia driver doesn’t load. Rather use the kernel from the liquorix ppa so you get updates, and install a newer firmware package manually
https://packages.ubuntu.com/de/jammy/linux-firmware
(Can be used on 20.04 without issue)
About the nvidia gpu: please run
sudo modprobe nvidia
and post any errors given.

Hello,

Thanks for your quick answer!

Rather use the kernel from the liquorix ppa so you get updates, and install a newer firmware package manually
Ubuntu – Details of package linux-firmware in jammy

Could you elaborate on how I can add this as a ppa? I usually use:

sudo add-apt-repository ppa:USER/REPO

Besides, it looks like the repo you suggested is for Ubuntu 22.04 right? If so, I’m on 20.04 LTS, could you point which one I should use please? (perhaps Ubuntu – Details of package linux-firmware in focal ?) Sorry I’m new to tweaking ppa with linux repo!

About the sudo modprobe nvidia, it keeps running but nothing prints after dozens of minutes :/

Best

The firmware is not a repo, it’s just a .deb firmware package. Just download it and install it manually. (dpkg -i <filename>)Firmware files are just “files” so the package is independent of architecture and ubuntu version.

liquorix ppa:
https://launchpad.net/~damentz/+archive/ubuntu/liquorix

Mmmh, strange, I can only see a .dsc file and a tar archive. I found online instructions to install those though!
However, this is installing 1.187 firmware, while I already had 1.187.31. Anyway, what should I do know?

  • switch to lightdm?
  • reboot?
  • try to reinstall nvidia directly?

liquorix ppa: Liquorix Kernel : Steven Barrett

Alright, thanks, I already had added this PPA :)

Click on “Architecture: all” then you can choose a mirror to download from.

Installing the liquorix kernel:
https://www.linuxcapable.com/how-to-install-liquorix-linux-kernel-on-ubuntu-20-04/

Ok i followed that exactly. It installed the amd64 package though (not sure whether that’s normal)

I rebooted and now I don’t have wifi anymore :/

Any advice?

Please create a new nvidia-bug-report.log.

Here it is!
nvidia-bug-report.log (10.8 MB)

(I tried to install the driver despite this problem, and it still failed)

Something went wrong installing the firmware, now no firmware can be found. Please post the output of
ls /lib/firmware/iwlwifi-so-a0-hr-b0*
and run
sudo update-initramfs -u

The file pattern doesn’t exist, but I have those:

/lib/firmware/iwlwifi-1000-5.ucode     /lib/firmware/iwlwifi-7265D-12.ucode
/lib/firmware/iwlwifi-100-5.ucode      /lib/firmware/iwlwifi-7265D-13.ucode
/lib/firmware/iwlwifi-105-6.ucode      /lib/firmware/iwlwifi-7265D-16.ucode
/lib/firmware/iwlwifi-135-6.ucode      /lib/firmware/iwlwifi-7265D-17.ucode
/lib/firmware/iwlwifi-2000-6.ucode     /lib/firmware/iwlwifi-7265D-21.ucode
/lib/firmware/iwlwifi-2030-6.ucode     /lib/firmware/iwlwifi-7265D-22.ucode
/lib/firmware/iwlwifi-3160-10.ucode    /lib/firmware/iwlwifi-7265D-27.ucode
/lib/firmware/iwlwifi-3160-12.ucode    /lib/firmware/iwlwifi-7265D-29.ucode
/lib/firmware/iwlwifi-3160-13.ucode    /lib/firmware/iwlwifi-8000C-13.ucode
/lib/firmware/iwlwifi-3160-16.ucode    /lib/firmware/iwlwifi-8000C-16.ucode
/lib/firmware/iwlwifi-3160-17.ucode    /lib/firmware/iwlwifi-8000C-21.ucode
/lib/firmware/iwlwifi-3160-7.ucode     /lib/firmware/iwlwifi-8000C-22.ucode
/lib/firmware/iwlwifi-3160-8.ucode     /lib/firmware/iwlwifi-8000C-27.ucode
/lib/firmware/iwlwifi-3160-9.ucode     /lib/firmware/iwlwifi-8000C-31.ucode
/lib/firmware/iwlwifi-3168-21.ucode    /lib/firmware/iwlwifi-8000C-34.ucode
/lib/firmware/iwlwifi-3168-22.ucode    /lib/firmware/iwlwifi-8000C-36.ucode
/lib/firmware/iwlwifi-3168-27.ucode    /lib/firmware/iwlwifi-8265-21.ucode
/lib/firmware/iwlwifi-3168-29.ucode    /lib/firmware/iwlwifi-8265-22.ucode
/lib/firmware/iwlwifi-3945-2.ucode     /lib/firmware/iwlwifi-8265-27.ucode
/lib/firmware/iwlwifi-4965-2.ucode     /lib/firmware/iwlwifi-8265-31.ucode
/lib/firmware/iwlwifi-5000-5.ucode     /lib/firmware/iwlwifi-8265-34.ucode
/lib/firmware/iwlwifi-5150-2.ucode     /lib/firmware/iwlwifi-8265-36.ucode
/lib/firmware/iwlwifi-6000-4.ucode     /lib/firmware/iwlwifi-9000-pu-b0-jf-b0-33.ucode
/lib/firmware/iwlwifi-6000g2a-5.ucode  /lib/firmware/iwlwifi-9000-pu-b0-jf-b0-34.ucode
/lib/firmware/iwlwifi-6000g2a-6.ucode  /lib/firmware/iwlwifi-9000-pu-b0-jf-b0-38.ucode
/lib/firmware/iwlwifi-6000g2b-6.ucode  /lib/firmware/iwlwifi-9000-pu-b0-jf-b0-41.ucode
/lib/firmware/iwlwifi-6050-5.ucode     /lib/firmware/iwlwifi-9000-pu-b0-jf-b0-43.ucode
/lib/firmware/iwlwifi-7260-10.ucode    /lib/firmware/iwlwifi-9000-pu-b0-jf-b0-46.ucode
/lib/firmware/iwlwifi-7260-12.ucode    /lib/firmware/iwlwifi-9260-th-b0-jf-b0-33.ucode
/lib/firmware/iwlwifi-7260-13.ucode    /lib/firmware/iwlwifi-9260-th-b0-jf-b0-34.ucode
/lib/firmware/iwlwifi-7260-16.ucode    /lib/firmware/iwlwifi-9260-th-b0-jf-b0-38.ucode
/lib/firmware/iwlwifi-7260-17.ucode    /lib/firmware/iwlwifi-9260-th-b0-jf-b0-41.ucode
/lib/firmware/iwlwifi-7260-7.ucode     /lib/firmware/iwlwifi-9260-th-b0-jf-b0-43.ucode
/lib/firmware/iwlwifi-7260-8.ucode     /lib/firmware/iwlwifi-9260-th-b0-jf-b0-46.ucode
/lib/firmware/iwlwifi-7260-9.ucode     /lib/firmware/iwlwifi-cc-a0-46.ucode
/lib/firmware/iwlwifi-7265-10.ucode    /lib/firmware/iwlwifi-cc-a0-48.ucode
/lib/firmware/iwlwifi-7265-12.ucode    /lib/firmware/iwlwifi-Qu-b0-hr-b0-48.ucode
/lib/firmware/iwlwifi-7265-13.ucode    /lib/firmware/iwlwifi-Qu-b0-jf-b0-48.ucode
/lib/firmware/iwlwifi-7265-16.ucode    /lib/firmware/iwlwifi-Qu-c0-hr-b0-48.ucode
/lib/firmware/iwlwifi-7265-17.ucode    /lib/firmware/iwlwifi-Qu-c0-jf-b0-48.ucode
/lib/firmware/iwlwifi-7265-8.ucode     /lib/firmware/iwlwifi-QuZ-a0-hr-b0-48.ucode
/lib/firmware/iwlwifi-7265-9.ucode     /lib/firmware/iwlwifi-QuZ-a0-jf-b0-48.ucode
/lib/firmware/iwlwifi-7265D-10.ucode

And running the command got me :

update-initramfs: Generating /boot/initrd.img-5.18.8-051808-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8125b-2.fw for module r8169

So I :

I managed to get the wifi back (and sound) by adding ibt=off in the grub (suggested here Linux 5.18 NVIDIA module won't load: ` Missing ENDBR: _portMemAllocatorAllocNonPagedWrapper+0x0/0x10` · Issue #256 · NVIDIA/open-gpu-kernel-modules · GitHub)!

Now we can get back to lightdm & nvidia driver :)

Some updates: after rebooting and having to go into tty disabling the graphical manager, the ibt=off seems to have helped me install the NVIDIA driver and CUDA!

I had to reconfigure and reinstall gdm3 afterwards and I’m not sure whether this kernel config is a long-term solution but I can finally access my GPU :)

If someone knows how to recover the possibility to use lightdm though, I’m all ears!

Hi all!

I have a similar problem with the same laptop of @fgfm03 . I tried to install ubuntu 20.04 in a dual boot system with Windows 11. I was able to install Ubuntu switching uefi mode to ahci instead of raid and disabling secure boot. I installed Ubuntu 20.04 with kernel 5.13 as default, but i could not boot and i solved adding nomodeset to the grub configuration but my wifi and bluetooth modules did not work. From there I installed kernel 5.18.8-051808-generic and that solved the issues with bluetooth and wifi boards, when i tried to install nvidia driver ( I tried from 470 to 515 using both ubuntu software&update tools and apt ) everything seems to go fine but when I run nvidia-smi it gives me this message: “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”
I tried to add “ibt=off” on grub configuration but it did not work both doing it before the driver installation and after.

I send you also my nvidia bug report.

nvidia-bug-report.log (617.6 KB)

Actual configuration:

Dell G15 5521 special edition
Ubuntu 20.04 Kernel 5.18.8-051808-generic
Linux-firmware: 1.187.31
Actual Nvidia Driver: 515

Any suggestions? thanks

The mainline kernel is incompatible, please use the liquorix ppa to get a compatible one.

Thank you generix! Installing liquorix kernel solved the issue even without using ibt=off option.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.