Ubuntu 20.04.4 - HP ZBook Studio G8 Mobile WorkStation - driver fails


I have installed Windows 10 21H2 and Ubuntu 20.04.4 LTS on an HP ZBook Studio 15.6 inch G8 Mobile WorkStation laptop with RTX 3080.

NVIDIA driver works on Windows but not on Ubuntu.
I have tried several options such as:

among others solutions but I always get

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
nvidia 0000:01:00.0: can't change power state from D3cold to D0 (config space inaccessible)

and Mesa Intel @ UHD Graphics as active graphic driver

Here is the bug report log: 5.13.0-35-generic-nvidia-bug-report.log.gz (200.6 KB)

Please, help

From my observation, it’s an intel bug in the kernel. Kernels 5.8-5.12 and 5.15 works for your platform, 5.13,5.14 and 5.16 don’t.
Please try enabling the ‘proposed’ repo which includes the 5.15 kernel (at least I think so).


Hi @generix

Many thanks for your solution, after 2 days now the driver work :)

By the way, I tried with the following kernels (,, but they don’t recognize the wifi and the touchpad. Finally, I installed the 5.10.0-1044-oem kernel from the ‘proposed’ repo.

Here, as a note to my future self and anyone else who has the same problem, are the clean and organized steps I followed to set up the driver:

  • Check the certified system (Certified hardware | Ubuntu) for HP ZBook Studio 15.6 Inch G8 Mobile Workstation PC and identify the provided kernel: “This system was tested with 20.04 LTS, running the 5.10.0-1044-oem kernel”

  • Enable the ‘proposed’ repository (Software & Updates > Developer Options)

  • Remove NVIDIA driver

    sudo apt purge nvidia-*
    sudo apt autoremove
    sudo apt autoclean
  • Install the 5.10.0-1044-oem kernel

    sudo apt install linux-image-5.10.0-1044-oem linux-headers-5.10.0-1044-oem
  • Blacklist NVIDIA nouveau driver (adapted from How to disable/blacklist Nouveau nvidia driver on Ubuntu 20.04 Focal Fossa Linux)

    sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
    sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
    # update all kernels
    sudo update-initramfs -u -k all
  • Restart and boot using the new kernel (Advanced option for Ubuntu > Ubuntu, with Linux

  • Uninstall previous kernels

    List all installed kernel using dpkg --list | grep linux-image

    sudo apt purge linux-image-5.13* linux-headers-5.13*
    sudo apt autoremove
    sudo apt autoclean
    sudo update-grub
  • Install NVIDIA driver

    Optionally, list the recommended driver using ubuntu-drivers devices

    sudo apt install nvidia-driver-510
  • Modify GRUB to show “Ubuntu, with Linux” as the first option in the menu

    Edit the file /boot/grub/grub.cfg and replace the first menu entry (menuentry 'Ubuntu' ...) with the “Ubuntu, with Linux” menu entry (menuentry 'Ubuntu, with Linux menu' ...)


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.