255.00.26 installation fails on linux.

At the moment I can’t seem to install the beta vulkan driver. Here is the nvidia-installer.log

http://pastebin.com/na7EEirF

What version of Linux and what compiler? I’m able to install the driver on CentOS 7 with GCC 4.8.5.

$ /bin/cc --version
cc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-4)
Copyright © 2015 Free Software Foundation, Inc.

$ lsb_release -d
Description: CentOS Linux release 7.2.1511 (Core)

Looks like you’re using Linux >= 4.3 which isn’t supported. It’s rather trivial to patch the driver to get it to build and work.

@@ -360,7 +360,8 @@ nv_procfs_read_registry(
     registry_keys = ((nvl != NULL) ?
             nvl->registry_keys : nv_registry_keys);
 
-    return seq_printf(s, "Binary: \"%s\"\n", registry_keys);
+    seq_printf(s, "Binary: \"%s\"\n", registry_keys);
+    return 0;
 }
 
 static ssize_t
@@ -560,7 +561,8 @@ nv_procfs_read_text_file(
     void *v
 )
 {
-    return seq_puts(s, s->private);
+    seq_puts(s, s->private);
+    return 0;
 }

Just apply this patch to kernel/nvidia/nv-procfs.c

If you’re using a newer kernel your distro probably also ships xorg-server 1.18 which also isn’t supported by this branch so you will have to downgrade that to 1.17.

Using current Vulkan driver is not yet supported in ubuntu 16.04? It uses kernel 4.4
Is Vulkan yet supported Proprietary GPU Drivers PPA [**]. It has version 361

https://developer.nvidia.com/linux64bit
NVIDIA-Linux-x86_64-355.00.26.run

[**] https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa?field.series_filter=xenial

It only builds with the patch I provided on Linux >= 4.3. That’s nothing special. NVIDIA has good support for the latest stable kernel with the official driver, but this driver was based on an older branch. Every 1-2 years it might occur once that bleeding edge distros like Arch Linux ship the latest stable kernel that isn’t officially supported by a new release of the driver so they just ship it with a patch.

Update: Ubuntu updated Vulkan PPA to support nvidia-355-vulkan
https://launchpad.net/~canonical-x/+archive/ubuntu/vulkan?field.series_filter=xenial

trying now (doing install on USB key)

Linux 4.3, Xorg 1.18, gcc 4.9.3, Void Linux.

If this branch doesn’t support xorg 1.18 then I’m just going to have to wait, downgrading is a hassle I don’t want to deal with.