Does 440.82 support Vulkan 1.2?

Same as 440.66? Guys from Nvidia - you should have this info available somewhere in release notes.

AFAIK, no.


This one has vulkan 1.2.

“AFAIK” based on what? the page you gave me I have already checked. The release date and version of 440.82 is newer than that of 440.66 .So are you saying based on installed 440.82 vulkan version check?

Please try to be more polite.
Check the page again.
The link to vulkan 1.1 leads to 440.82:
http://www.nvidia.com/object/unix.html
The vulkan beta driver: https://developer.nvidia.com/vulkan-beta-4406615-linux
has version 1.2.
So clearly you didn’t check properly.

Mart,I am polite. (You should have see my face when I was writing the question ;) )

But,again,please show me where it is written? The link you posted tells nothing about Vulkan Version, The link you specified doesn’t tell it is 1.1 (only).So where your info comes from?

Vulkan 1.1 support is available for Windows and Linux in our general release drivers available here:

Vulkan 1.2 support is available in Windows driver version 443.24 and Linux driver version 440.66.15.

Sorry, but I can’t do the reading for you.

" Vulkan 1.2 support is available in Windows driver version 443.24 and Linux driver version 440.66.15." - and you say this means there is no Vulkan 1.2 in 440.82? That’s not what I understood.

I don’t know what else to say.
1.2 is only available in the vulkan beta driver.

Okey thank you.
Somebody from NVIDIA stuff can confirm the latest Linux driver supports {or doesn’t) Vulkan 1.2?
Thanks.

I have 440.82 installed.
vulkaninfo tells me:

VK_LAYER_NV_optimus (NVIDIA Optimus layer) Vulkan version 1.1.119, layer version 1:
    Layer Extensions: count = 0
    Devices: count = 1
            GPU id  : 0 (GeForce RTX 2080 Ti)
            Layer-Device Extensions: count = 0

Thank you very much!

you need install drivers
and install vulkan-tools

now in terminal write this
vulkaninfo | grep NVIDIA

VK_LAYER_NV_optimus (NVIDIA Optimus layer) Vulkan version 1.2.140, layer version

The reason I asked was because installation of the drivers via .run files has always been a pain and caused wreck of the system. There was not a single time I was able to install drivers via .run without destroying ligthDM or anything else in Linux. (see countless questions on the topic in Ubuntu and Linux forums)
So clearly it is nice to know if the driver supports the Vulkan version in interest before spending hours installing it. Also I am really surprised to know that newer version of the driver supports only the older version of Vulkan. Why?

My question exactly. This page leads to the general driver that claims to support of Vulkan 1.2, but it does not: https://developer.nvidia.com/vulkan-driver

The official nvidia repository always fast-forwarding the driver package to the newest version, deleting the old ones. At this moment it is 440.100: https://download.nvidia.com/opensuse/leap/15.2/x86_64/

I.e. the /etc/vulkan/nvidia_icd.json file installed from this package contains: “api_version” : “1.1.119”. Checking extensions in runtime also does not reveal Vulkan 1.2 presence.

So I was wonder how could it be, is it true that only 440.66.17 had Vulkan 1.2 and then it was erased from the next releases? I would not mind to downgrade to that version, but nvidia does not offer that package or any newer beta package.