3.1 Jetpack installed - bugreport

It now powers on by chance 50/50.
Either it is running at once or involves magic intrinsic manipulations with multiple poweroff poweron actions accompanied with detaching/attaching of all connected cables.
What could be the cause?

Hi Andrey1984,

It looks like a hw issue. Does your board work normally when Jetpack3.0?

Never experienced issues with Jetpack3.0.
The board worked normally with Jetpack 3.0 until upgrade, as it seems to me.

Can it be tested?

Hi Andrey1984,

Could you describe the problem in detail? Do you mean sometime TX2 has no reaction after power on?
No any kernel log or bootloader log?

  1. Powered off the device.
  2. Pressed Power on button
    It wont start
  3. Detached miniusb and USB 3.0 connected mouse and keyboard
    It wont start
    4)Detached power cord and attached it again
    It wont start
  4. attached mini usb and usb.30 connected mouse and keyboard
  5. Detached and attached Power cord
    It resulted to come up with network adapted read lighting , but no display image

n-1) detached miniusb and usb 3.0 & detached and attached power cable
It started

kern.log (792 KB)

Shall I make more power off - power on experiments?
I have found kernel log within /var/log/kernel.log and I shared it.
I shall try attach different mouse/keyboard, perhaps.

Experiment N1:
Powered off the device
Detached power cable
Detached mouse&keyboard
Attached another mouse&keyboard
Attached power cable
Powered on the device.
It works.

Experiment N2
I pressed restart in Ubuntu.
It feels as if it will never come up.
It resulted in several denial on powering on.
10-20 times it didnt power on.
Finally I detached hdmi and it signaled that it got started with network led. And I attached hdmi and it works.
kern.log (1010 KB)

Shall I flash Jetpack 3.0?

May I confirm your situation:

  1. What did you mean “It resulted in several denial on powering on.”? Does tegra totally not power on and no bootloader log is shown through UART?

  2. You said you used restart button in Ubuntu. What about the restart button on devkit?

  3. Please try Jetpack3.0 again to see if this issue is really related to SW BSP.

It seems that hdmi connector unplugged results in more probability of successful start of the devboard.
However, that required to plug hdmi “on-hot” which is not good, as it seems to me.
In regards to what you asked:

  1. On power on a green led radiate green lights. Neither led on LAN nor anything at display appears.
    It seems that tegra doesn’t power on, but to which extent it wont power on - it is difficult to determine. I use hdmi output and network led together with keyboard numlock/capslock to indicate if the system has started.
    How do I find a bootloader log through UART? I am afraid I am not aware how to find bootlog and not sure what is the meaning of UART there.
  2. Once the board is started successfully - it works fine, perfectly. But on any sort of restart or power on/power off it is likely to cause troubles. Either I type sudo reboot or use Ubuntu button or use reset button at devboard - the result is likely to be the same - the green led at the devboard does up, but neither hdmi outputs, nor keyboard capslocl/ network led would react.
  3. I shall try Jetpack 3.0 again and will update you soon.
    Thank you for your questions.
    Andrei

I think I have no cable for UART
It wasn’t presented in the devboard package. Was it?

It seems that the issue might have been caused by disk drive issue at Host.
My observation when I been installing Jetpack 3.0 and 3.1 from destination[source] /mnt/media/567567ghj-5675fghf-67868ghjgh-67867/home nvidia/path was that the installer starts with an error from there.
So I repartitioned host disk drive so that I have enough size to tun the installr from /home folder which caused no error.
Finally I reinstalled 3.1 that way and it rebooted fine after reflash.
Thanks.
I’ll keep you updated.

Having too little space on host has caused several failures which were not obvious as to cause when it should have worked. FYI, there is no serial console cable included. Here’s information on adding it:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Seems to be resolved, finally.
Thank you.

Seems reappeared.
Had to detach usb.30 and hdmi to get the system booted.
Shall try reflash to 3.0 :(
kern.log (425 KB)

it seems to start most likely when hdmi cable is detached
2 of two detachment resulted in successful boot.

Or 6 attempts from which 4 was reset with hardbutton and 2 was poweron with poweron button 5 was successfull: 3 times reset with hdmi detached + 2 times poweron with hdmi detached, and 1 attempt failed - to power on the device with hdmi attached.
Could hdmi attached and wth converter hdmi-vga be the cause?

Jetpack 3.0 installed - starts fine at once.
How shall I investigate the issue furtherly?