3070 TI fans do not stop at idle

While configuring my new Arch installation I noticed that the fans of my 3070 TI keeps spinning for way more than they do on Windows. I’ve sometimes seen them stopping, but only in very rare and for now unpredictable scenarios.
I’ve tried using nvidia-settings with the following command, but the speed value is reported to be invalid (has to be between 30 and 100, and those values do work).

nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUTargetFanSpeed=0" -a "[fan:1]/GPUTargetFanSpeed=0"

Tried both X11 and Wayland without any difference (log is generated while using Wayland, if that matters).
Thanks in advance for the assistance.

nvidia-bug-report.log.gz (322.2 KB)