Enable GPU fan settings has no effect

I have Gigabyte GeForce RTX™ 3050 EAGLE OC 8G video card and use Ubuntu 22.04. The fans make an annoying noise when they intermittently start from 0 RPM for a short time and stop. Nvidia X Server Setting app allows setting the GPU fan speed, but adjusting the Fan 0 Speed slider has no effect on its speed:

Is there a solution to this issue?

1 Like

No, it’s running as user (default Ubuntu configuration). Do you mean that I will have to use Ubuntu as root in order to have the fan speed setting working?

Thank you. I edited /etc/X11/Xwrapper.config to contain:


and it runs as a server now:

paul@desktop:~$ ps -fC Xorg
UID          PID    PPID  C STIME TTY          TIME CMD
root        2056    2054  3 15:08 tty2     00:00:07 /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolist

Fan 0 Speed slider now sets the Target Speed:

BTW, with the Target Speed set at 50%, will it be automatically exceeded when high GPU use requires?

Is the fan running at lower rpm making less noise than when it runs at full rpm?

Yes, it does, but this wasn’t my problem. Abrupt start from 0 rpm and stop was producing a short grumbling noise. Nothing dramatic, but distracting enough to look for solutions.

Thanks for confirming. My problem is that rpm is reported to lower, but the noise level keeps being as high as for 100% fans. I am wondering if my card has some issue or maybe, being a three-fan card, one of the fans is not touched by the settings of nvidia-settings (see here Nvidia 4090 with 3 Fans but Nvidia Settings shows 2 Fans)

I think you are onto something. My card has 2 fans, but as on the screenshot above, only Fan 0 is shown. Using a single control channel for 2 fans with tachometers may create problems.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.