>=334.21 Redrawing problems in Gnome 3.10/3.12 - GTX 580

Hi @rtcm,

since Friday, I’m experiencing a similar bug with newest nvidia drivers 340 and the gnome shell. I wrote down everything here https://devtalk.nvidia.com/default/topic/770136/linux/ubuntu-gnome-3-10-lts-14-04-redraw-glitches-with-nvidia-340-29/

Are there any news concerning this bug? Could maybe NVIDIA tell us the current state of the issue?!

Greetings, Thomas

I’m running Gnome 3.14 Beta 2 on Arch Linux now and this issue seems to have been minimized by the Gnome developers but not 100% fixed. I can still end up with folders, which have one character missing during the renaming process. It isn’t as easy to reproduce as it was, though. I have to type for example “test test test” extremely fast to end up with “test test tes”. When I type it slowly everyting is correct and the last character doesn’t end up missing. When I click inside nautilus to finish the renaming the last character is drawn. Gnome Shell is less jerky in general. The overview animation was never smooth at 50 Mhz now it is.

Running Arch 64-bit with XFCE and Compton. I just received updated Nvidia drivers, 343.22-1 and I still get the redraw issue where parts of the screen should update but won’t until I move the mouse over the area or move the window. It’s most obvious in a terminal, hit enter on a command and you won’t see the command output, its like the command is taking forever. Move the terminal window a pixel and the output appears (ie, the window is redrawn and updates). Also settings panels with tabs, clicking through the tabs and suddenly a tab gets activated but its contents is not shown until you move your mouse into the area, then it suddenly updates.

As a workaround I need to issue the command:

nvidia-settings -a InitialPixmapPlacement=0

This issue is not just with Gnome or Cinnamon for that matter, any WM that uses OpenGL compositor with the exception of KDE seems to suffer from this issue.

I tested with a GTX580 (which I sold) and now with a GT430.

In another thread its been suggested that Compiz should already have been fixed but I can tell you after compiling everything from the latest source this issue still exists.

Last but not least, no issues with Nouveau.

Thanks for the tip, pedro_ii. I notice a pretty big hit in performance when I use that setting under Gnome Shell 3.12.2 on Arch. So for now I just leave it on maximum performance. Sad.

About once a year some really nasty Nvidia bug hits and it really destroys my system usage. Thankfully, it seems they’re getting a little quicker about it - I remember the 70 driver really effing up my Gnome Desktop all the time way back when. I’m so thrilled that Intel has upped the performance of their integrated chips - they’re a pleasure to use. This might be my last Nvidia card. :)

Still, thanks to the Nvidia team for looking into the matter. I really can’t wait for a fix.

Unfortunately, the performance setting doesn’t work for me.

Intel is great for regular desktop use or HTPC applications, but for FPS gaming they still aren’t up to snuff.

I might just switch to AMD this time around. They have their share of issues too, but at least they are much more active and involved with the open source community.

I have to agree: This is absolutely maddening. I have a better desktop experience when I use my old GMA intel laptop. The current driver is not behaving properly and is the source of many woes in my desktop experience. Maximum performance helps the case but there’s a really ugly sense of lag and unresponsiveness with the whole thing. Can we at least get some response? Again, my freaking 2007 laptop runs better than my GTX 560 and it has been for a while now.

@pedro_ii: Have you seen the capabilities of the new intel chips? Sure, they won’t run brown-grey-shooter 2014 on maximum but they’re enough for many of the games out there. Not everyone partakes in FPS nonsense. :)

Is there someone we can contact directly about this? Maybe the people that are in charge of this aren’t aware of the seriousness of this bug?

Also in case someone doesn’t know there is a fix (probably more like hack) for this issue in a standalone X compositor called Compton (https://github.com/chjj/compton). You have to compile and run the git version though, not the release version. To enable the fix run the compositor like this:

compton --xrender-sync --xrender-sync-fence -b --vsync opengl-swc

Now I don’t think you can replace the gnome compositor with Compton but you can use it with, say, MATE. It works well for me.

Thanks for the tip, Sporbie - I’d prefer to stick with Mutter. Speaking of which, Arch just got gnome 3.14 and I’m still having exactly the same issue, so I don’t know how a poster above has fewer issues (particularly since neither patch has been pushed yet.

Please, please nvidia. T.T

I’ve been lurking silently for months. I have witnessed a pitiful lack of engagement to issue even the most basic of statements. I plead on my stubby little legs and pray that the gods on Nvidia Mountain could supply those cursed with a fix for this soul-crushing issue.

I have been through hell and back with Nvidia cards, partaking in faustian deals for that great 3D performance.

Alas, no more! The history of nvidia pulverizing my poor sleep capabilities will be no more! My computer will not lack KMS functions no more! My computer will not tolerate the decade of bugs no more! For I, too, have looked upon the glorious Intel, and while I may not partake in their graphics in favor of an AMD card, these capabilities drive my painstaken heart away from the devil’s poisonous drink of better 3D performance. Yes, I will suffer the loss of top-tier performance as much as my firstborn, but within the pain will be born a new hope for desktop usage.

Come join me, brethren! Come, let us visit the mount of dreams, wherin one can type without constant glitchings! Wherin one can forget the great slaughters of old whence stability issues were not addressed for months! Life remains such a mysteriously glorious experience, do not waste it on constant driver updates and hackarounds for your desktop! Come frolick in the fields of liberalism, where the desktop is treated as an equal.

Come! The time is nigh, for at this very moment I have successfully run more computers with the infamous AMD beast (open drivers) than with Nvidia in recent years. This thread should be the clarion call to better our lives.

…or, if you still like this fscking way of doing things, at least whine like a baby. Because that’s the only way things get done around these parts. Whine loudly.

Wow great post, great sense of humour. :-) (and also – your statements are so TRUE)

anything? is this not where nvidia devs talk?

Why do you hate us, Nvidia?

seriously, WTF can’t we get any sort of confirmation or human interaction?

Yeah, at least some sort of acknowledgement that they know about the issue would be nice.

I still have the issue with driver 343.22, and gnome 3.14.1.5, GT 750M on arch linux.

HELLOOOOOOOOOOOOOO

I think the lack of proper customer support from nVidia is becoming a problem here…

This issue affected my latest purchase of a laptop, it’s Intel only, no nvidia crapware for me in the future!

Well, if you add power consumption and no Optimus for Linux, having an nVidia card in a Linux laptop isn’t even remotely an option…

I still have this bug in 346.16, but it’s not like in the video I posted where something would not draw until I clicked inside the application again. Now everything draws at a certain point in time, but sometimes with a noticable delay. When I name a folder “Test” the first three letters appear immediatelly, but the last t only appears after some 200-500ms for example. This also only happens, when the card runs in the lowest performance state (50 Mhz). Desktop is Gnome 3.14.2

humm… any update from nvidia? i dont mind the bug but communication will be good. :)