346.22, 343.36 regression: no DP1.2 daisy-chaining on GTX770. Worked with 343.22.

The setup: GTX770, 3 daisy-chained Dell U2415 each with DP1.2 enabled, Samsung BX2240 on DVI (for framebuffer and EFI, which you’re not showing via DP connections). X is loaded via startx with Samsung BX2240 disabled (when I figured out that having all 4 screens is beyond the documented maximum size).

The 343.22 driver was not flawless and I had to manually reconfigure the Screen after almost each boot: driver seemed to ignore the settings in xorg.conf created by nvidia-settings and only 1 or 2 DP monitors had signal initially. In the latter case it might be DP-1.8 and DP- with DP-1.1.8 going into sleep due to no signal. The cables are standard Dell cables shipped with the monitors.

I tried to upgrade to a newer version, did emerge nvidia-drivers, rebooted. Had to wipe xorg.conf and .nvidia-settings-rc. And now the driver is stable. In the sense it does NOT work. No daisy chaining. At all. Kernels 3.17, 3.18.1, both stable 343.36 and beta 346.22.

So I am quite frustrated as now (since 343.22 is no longer in official gentoo tree) I don’t have 2 DP monitors at all. And I’ve already spent quite a bunch of time for trial and error.

Information was gathered with 346.22:
uname -a

Linux tower 3.18.1-gentoo #1 SMP Thu Dec 18 00:00:31 MSK 2014 x86_64 Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz GenuineIntel GNU/Linux

dmesg shows some problem with 346.22, which is not present with 343.36:

[  949.657984] WARNING: CPU: 0 PID: 9780 at drivers/gpu/drm/drm_ioctl.c:143 drm_setversion+0xcf/0x16e()
[  949.658021] No drm_driver.set_busid() implementation provided by nvidia_frontend_exit_module [nvidia]. Use drm_dev_set_unique() to set the unique name explicitly.
[  949.658022] Modules linked in:
[  949.658023]  nvidia(PO)
[  949.658025] CPU: 0 PID: 9780 Comm: X Tainted: P        W  O   3.18.1-gentoo #1
[  949.658025] Hardware name: Gigabyte Technology Co., Ltd. Z87X-UD5H/Z87X-UD5H-CF, BIOS F8 01/17/2014
[  949.658026]  0000000000000009 ffff8800ca24bcf8 ffffffff81572e59 000000000000003b
[  949.658028]  ffff8800ca24bd48 ffff8800ca24bd38 ffffffff8103d222 ffff8800ca24bf24
[  949.658029]  ffffffff8130511e ffff88041d0c0000 ffff8800ca24be18 ffff88041d063580
[  949.658030] Call Trace:
[  949.658033]  [<ffffffff81572e59>] dump_stack+0x46/0x58
[  949.658035]  [<ffffffff8103d222>] warn_slowpath_common+0x77/0x91
[  949.658037]  [<ffffffff8130511e>] ? drm_setversion+0xcf/0x16e
[  949.658038]  [<ffffffff8103d27d>] warn_slowpath_fmt+0x41/0x43
[  949.658040]  [<ffffffff8130511e>] drm_setversion+0xcf/0x16e
[  949.658041]  [<ffffffff81304f4a>] drm_ioctl+0x3a2/0x3f3
[  949.658043]  [<ffffffff8130504f>] ? drm_version+0x8b/0x8b
[  949.658045]  [<ffffffff810f75ef>] ? do_filp_open+0x35/0x85
[  949.658046]  [<ffffffff810f93bf>] do_vfs_ioctl+0x353/0x417
[  949.658047]  [<ffffffff810f6fa3>] ? putname+0x23/0x2c
[  949.658049]  [<ffffffff810ea2bf>] ? do_sys_open+0x1bf/0x1d1
[  949.658050]  [<ffffffff810f94bc>] SyS_ioctl+0x39/0x61
[  949.658052]  [<ffffffff81578312>] system_call_fastpath+0x12/0x17
[  949.658053] ---[ end trace c07f38d7cb5aa8ee ]---

I’d attach the nvidia-bug-report.log.gz but this box doesn’t have an ‘attach’ button. Or is it not showing due to some reason? Found the button.

If you’re wondering why there are 2 errors in Xorg.0.log, I believe its because I modprobed nvidia manually right before startx.
nvidia-bug-report.log.gz (193 KB)

To elaborate on this.

I booted into Windows 7 x64 Professional and I can see no DP daisy-chained monitors too. Previously they were working with whatever driver I had.

So I updated to 344.75 (latest) from nvidia site with a clean install. Nothing changed - the daisy chained monitors are not recognized by nvidia control panel.

Nvidia, could you please elaborate on this since I already have a feeling you owe me a couple thousand bucks.

dvn_dummy, Looks issue reproduce with 346.22 and not with 343.22 . Please provide nvidia-bug-report for both the drivers for repro and no-repro cases. Make sure to start X in verbose mode [startx – -loverbose 6 &] before capturing nvidia-bug-report.

Its strange that on Windows earlier its was working and now its not.

Hi Sandip.

Sorry for a delayed response.

Unfortunately I can’t reproduce the issue any longer. I actually found some strange behavior with DisplayPort 1.2 support in both Linux and Windows. I’ve tried many different scenarios and could not get any consistent results.

The only reproducible case (somehow working) was if I connect the last monitor in the chain as DP1.1 I will get the monitors show up in Windows and Linux, but only 2 last monitors in the chain. The first one out of 3 would not light up.

Also X startup with DP1.2 is incredibly slow on Linux: my system boots to console in less than 5 seconds and then I have to wait ~20 seconds for the screens to react on startx, xorg logs show this time spent in NVIDIA driver. The X startup time with all 3 monitors in DP1.1 mode is approx. 1 second.

So finally I got tired of all this non-sense and got rid of the video card. Now I do not use DisplayPort 1.2 mode and daisy-chaining specifically since it is obviously not yet ready or in any way stable.

Unfortunately to achieve this I had to buy a GTX 980 to replace my 6 month old GTX 770 - it has 3 DisplayPorts. Current setup has been running for a week or so and so far I experienced no problems with it as well as I had no need to configure it anyhow.

Hi, does anyone of you know if the bug has been fixed in the latest releases? Thanks in advance!