375.10 for GTX 1050 on Centos 7.4

Hi,
I’m trying to install the driver for GTX1050 on my Centos 7.4 desktop, where the kernel version is 3.10. I have downloaded NVIDIA-Linux-x86_64-375.10.run and followed instructions to install it. During the compile, the compiler complains that linux/fence.h is not found. Is it because the kernel is too old to be supported in this package? I see in the README file that the minimal Linux kernel requirement is “2.6.9* and newer”…

Any suggestions? Thanks.

The centos kernel is heavily patched, indeed you need a newer nvidia driver package than 375.10.

Do you mean there is a newer version of the driver that does not need linux/fence.h? That’s a good news. Do you have a suggestion of the driver version? I thought 375.10 was the latest one for GTX1050…
Thanks.

I just tried NVIDIA-Linux-x86_64-384.98.run. It compiles, but I can not get it work. It stuck somewhere in the next booting. I tried a few “fixes” found in on the web, but none of them works.

A naive question: why don’t Nivinda work with Linux guys to simply provide a rpm?

When stuck, can you switch to vt and run nvidia-bug-report.sh, then attach the tar.gz file it creates to your post?

Hi generix, thanks for the reply. The tar.gz is attached. Please let me know if you have any suggestion. Thanks. BTW, if it’s useful, I’m setting up my second monitor.
nvidia-bug-report.log.gz (111 KB)

The driver seems to load fine but the nvidia gpu doesn’t detect any monitor and exits. In case you’re trying to run the nvidia without display, you have to add
Option “AllowEmptyInitialConfiguration”
to the device section of your xorg.conf.
If you have a monitor connected to the nvidia, check cabling.

I have added this option, but it still get stuck. I have the new debug output in the attachment. Could you please take a look? Thanks.
nvidia-bug-report.log.gz (109 KB)

Looks like you have to point the driver to the right device since you have the intel gpu active, add
BusID “PCI:1:0:0”
to the device section of xorg.conf, retry.

Thanks a lot. It works now!
BTW, if it’s easy to you, how can I setup the other monitor, as it’s disabled now? I guess I might just need to add it in the xorg.conf, but have no idea how…
They could co-exist, right?

I’m not quite sure what your current setup is, please tell me about it and post attach your current /var/log/Xorg.0.log. Normally, you would not have to configure anything, just in your case because you have the integrated gpu still active. Do you have the second monitor connected to the onboard graphics? If so, plug it into the nvidia, a multi gpu setup takes a lot more config.

Thanks. I’m attaching the /var/log/Xorg.0.log and /etc/X11/xorg.conf. This desktop has two DVI outputs, which I guess are from two different graphic cards. Currently, during the booting, the info are shown in one screen, and once booted, it switches to another one. I tried to modify the xorg.conf but seems it’s unsuccessful…
xorg.conf.txt (2.09 KB)
Xorg.0.log (62.6 KB)

The 1050 should have some DisplayPort connectors, the easiest would be to buy a DisplayPort->DVI adapter, disable the integrated graphics in bios, plug the second monitor using the adapter into the 1050 and be fine.
If you can’t do this for whatever reason, you will have to set up a multi-gpu config like PRIME. Meant for laptops but should work for desktops,too. See this:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Thanks for the suggestion. It seems that setting up multi-gpu config is quite complicated. I will try to get an adapter.