GeForce GTX 1050 drivers not working with Linux OpenSuse 42.1 on a Asus Vivo Book Pro N580GD notebook

Hello,

I’m having an issue with a GeForce GTX 1050. I’m trying to install the Nvidia drivers (410.73 version) on an Asus Vivo Book Pro N580GD, with no luck. The operating system we are using is OpenSuse/Linux 42.1

The installation procedure is apparently successful, but after that I am not able to access the system in graphical mode once the drivers are installed (i.e., the system hangs), while I can access it in console mode.

Note that:

  • the nouveau drivers look correctly disabled
  • when manually running nvidia-xconfig at the end of the installation, I also provide the correct busid name (i.e., nvidia-xconfig -a --busid=PCI:1:1:0)
  • the procedure I used successfully worked for a HPE server

Any ideas?

Thanks

Please see this:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

I tried the solution but it didn’t work for me.

First, I run the scripts to set up the xorg.conf automatically reported attached in the following link, as per your answer:
bugfixes.promisedev.com/download/nvidia_prime/nvidia_prime.tar.gz

Then, I added the option “options nvidia_drm modeset=1” to /etc/modprobe.d/nvidia.conf and finally run “sudo mkinitrd” (equivalent of update-initramfs).

Unfortunately the command “sudo cat /sys/module/nvidia_drm/parameters/modeset” still returns ‘N’, And indeed the system still hangs with NVIDIA drivers installed

Is there anything else I need to do?
nvidia-bug-report.log.gz (1.03 MB)

The distro (Leap 42.1) is largely outdated and out of support for nearly two years by now, running kernel 4.1 and Xserver 1.17. It does not support your hardware, especially the Intel gpu which is needed to work in an Optimus system. The script also failed to create a correct xorg.conf because of that. Please upgrade to a distribution that runs at least kernel 4.14/ Xserver 1.18.

I upgraded to Leap 42.3, which is still supported, but I am now having different issues.

When running the Nvidia installer (410.93) I get following error message: “ERROR: Unable to load the kernel module ‘nvidia-drm.ko’.” You can find the log attached.

Note that nouveau driver looks correctly disabled and both gcc (4.8) and kernel files (4.4) are up to date
nvidia-installer.log (26.7 KB)

Please make sure that you disabled secure boot in bios.
Please post the output of
sudo lspci -d 10de:* -knn
and
sudo lspci -s 00:02.0 -knn

I’m sorry to say but Leap 42.3 is still not sufficient for your hardware. It only contains drivers for up to Intel Kaby Lake type cpu graphics (using the drm-kmp-default package) but you have a newer Coffee Lake CPU. So you need to upgrade to at least Leap 15 if you want to stay with SuSE.