390.157 driver no longer works with kernel 6.5+

Hi, I try to install Nvidia drivers with a suggested package of Ubuntu and I receive message error, I try to install with the file 390.157 and receive the same message, are you working to solve this?

uname -a:
Linux Z210 6.5.0-21-generic #21~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Feb 9 13:32:52 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

The 390 series is no longer supported. Please see Support timeframes for Unix legacy GPU releases | NVIDIA for more information.

Same issue.

Do any newer NVIDA drivers support a GTX 550 GPU?

Is there any workaround (in meantime I switched to a GTX 750 GPU with 550.54.14)?

Out of support drivers are only kept alive through user/distro patching. Seems canonical hasn’t yet decided whether the 390 driver will be kept
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/2028165
Meanwhile, you could use the ppa a user created
https://launchpad.net/~dtl131/+archive/ubuntu/nvidiaexp

1 Like

I hope this driver will support at least until Ubuntu 24.04 lts version. If nvidia decided not to support this driver anymore I hope Nvidia will open the legacy driver on GitHub so anyone can contribute to develop the driver for feature use.
I really want use latest Ubuntu lts version :)

I put a new package in the nvidiaexp PPA for running 390 on Ubuntu 24.04 with 6.8 kernel.
I can only test that package builds/installs in a VM. Please test it and let me know if it works. Hopefully, it does, and I don’t have to bother with it for 5 more years. ;)

EDIT: And don’t hold your breath on Nvidia open-sourcing anything.