415.13, 415.18 & 415.18.02 breaking Unity engine games in WINE

It seems that the 415.13 drivers have broken every Unity engine game I have on my system when loading through WINE (native Linux titles are fine). When attempting to load the game they crash at launch with an error GUI window that says ‘GetThreadContext failed’. Downgrading to any lower-numbered driver fixes this, including the more recently released 410.78.

I’ve personally tested this with Beat Saber, Cuphead and a few other VR games under Proton, and there are reports here of the same error under MTG Arena and Hearthstone. I’m on an RTX 2080 w/ Arch Linux, the other user did not specify GPU but is on Ubuntu.

Random guess is that it may be related to the following from the release notes:
“Removed the LinuxThreads version of the /usr/lib/libnvidia-tls.so library and replaced it with the NPTL one that was previously installed in /usr/lib/tls/. This fixes crashes on Debian systems when the /etc/ld.so.nohwcap file is present.”

i have the same issue, when i click to launch September 1999 with Steam Play a wild “GetThreadContext failed” appears on the screen and can’t launch the game.

I have the same issue with Hearthstone.

ArchLinux x64, Nvidia GTX 970M

Have same issue with Beat Saber.
ArchLinux x64, Nvidia GTX 1060.

Same for me with “RWBY: Grimm Eclipse” and “Stick Fight: The Game” for exemple. But I can disable DXVK as a workaround (PROTON_USE_WINED3D11=1 %command%).

410.78 and 415.18 broke Stationeers under Proton. 410.73 is the last driver that worked on my box.

Ubuntu 18.04.1, 4.15.0-39-generic, Nvidia GTX 1070 x2.

Subnautica same error

GetThreadContext failed

nvidia vulkan beta drivers 415.18.02

Arch Linux 4.19.4-zen, Nvidia 1080 Ti

Unfortunately, i must join the club.
Something is broken with nvidia 415.18.02 when used against proton and unity.

Same issue for me on Unity-based SteamVR games running with Proton. No issues with previous versions of the driver, but now that I’m on 415.18.02 it’s nothing but GetThreadContext failed. Hopefully it won’t take too long to get this sorted out.

Arch Linux 4.19.5-1-ck-skylake, GTX 1070

so 415.18.04 is out which fixes the issues at least according to the log. Will test ASAP. Already built the packages but can’t reboot just yet… will let everybody know here once i have tested.


Confirming. Subnautica runs now again! Thank you

That’s weird, log says: "Fixes regression with Unity games on Linux "
not, “Fixes regression with Unity games on Proton/wine” :)

415.18.04 fixes Fallout Shelter, but breaks some opengl games like Euro Truck Simulator 2 and American Truck Simulator. Im not capable of providing any detailed information, but it looks like it hangs/crashes on shader compilation.

Forgot to follow up on this when the patch came out but I can confirm 415.18.04 does resolve this issue.

You should probably find or make another thread for this, it isn’t a good idea to mix bug reports for different drivers and bugs into the same thread.

As Vash63 suggested please file a new thread for this issue (or send an email to linux-bugs [at] nvidia.com). As part of the new thread please attach the output of nvidia-bug-report.sh and include a brief description of the steps which you preformed that reproduced this issue.

I spent the last 30 minutes or so trying to reproduce the issue you had described on both American Truck Simulator and Euro Truck Simulator 2, I didn’t experience and hangs or crashes like you mentioned. Without a better understanding of how your system is setup (GPU, Distro, etc.) it’s harder for us to understand the problem that you’re running into and how to reproduce it.

Thanks for your reply lmiddlebrook and sorry for confusion i made here.

Since new mainline driver is live (415.22) and it does not crash ETS2 and ATS on my system i suspect it was something specific to 415.18.04 and my computer. To clear things up:

My system: Intel Core i7 (intel_pstate performance) and GTX 1060 6GB, Fedora 29 on 4.19.6 kernel, KDE plasma DE

Im not using any sort of third party repos for driver packages, im always installing from .run file.

Both games are running fine on 415.18, 415.18.02, then update to 415.18.04 introduces crashes i mentioned and finally reverting to any previous or updating to 415.22 fixes it again, so i assume it was a Beta thing or really it didn’t like my system.