5.7. Adding a New Manipulator problems

Hey there,
I am following the tutorial 5.7. Adding a New Manipulator and I have one question.

The Isaac sim version is 2023.1.1

https://docs.omniverse.nvidia.com/isaacsim/latest/advanced_tutorials/tutorial_advanced_adding_new_manipulator.html

I tried running the standalone workflow script from section 5.7.4. Controlling the Gripper

It said

2024-01-17 06:33:22 [13,190ms] [Warning] [omni.isaac.dynamic_control.plugin] Failed to find articulation at ‘/World/cobotta’
2024-01-17 06:33:22 [13,190ms] [Error] [omni.isaac.dynamic_control.plugin] DcGetArticulationRootBody: Invalid or expired articulation handle
2024-01-17 06:33:22 [13,191ms] [Warning] [omni.physx.tensors.plugin] Failed to find articulation at ‘/World/cobotta’
2024-01-17 06:33:22 [13,191ms] [Error] [omni.physx.tensors.plugin] Pattern ‘/World/cobotta’ did not match any articulations

I checked it in GUI by the Articulation Inspector through Isaac Utils > Workflows > Articulation Inspector and found the prim_path that corresponds to the articulation should be ‘/World/cobotta/world’

but if I have changed the script line 26 as

my_denso = my_world.scene.add(SingleManipulator(prim_path=“/World/cobotta/world”, name=“cobotta_robot”,
end_effector_prim_name=“onrobot_rg6_base_link”, gripper=gripper))

It make error as:

Exception: Prim path expression /World/cobotta/world/onrobot_rg6_base_link is invalid, a prim matching the expression needs to created before wrapping it as view

The usd file structure is as follows:

-World(defaultPrim)
----cobotta_pro_900
--------world
--------onrobot_rg6_base_link

Can anyone help me solve this problem and thank you so much in advanced for the help!

Hi! Same issue here. I try the Extension workflow, but I got the same errors.

Hi,I find if I use the Nvidia offical USD as follows:

assets_root_path = get_assets_root_path()
asset_path = assets_root_path + “/Isaac/Robots/Denso/cobotta_pro_900.usd”

It work correctly. And for this offical USD, the articulation prim path can be found as '/World/cobotta". So how to add articulation correctly? If I put select and right click on the ‘’/World/cobotta" Xform and “Add → Physics”, there is no “Articulation Root” option, for the origin USD builded from urdf as in 5.7.3.1 section

Hi! Can you send me this USD please? I cannot find the official one.

Sincerely
Alex

you can get it using the following code:

assets_root_path = get_assets_root_path()
asset_path = assets_root_path + “/Isaac/Robots/Denso/cobotta_pro_900.usd”

replacing the script line 14

asset_path = “/home/user_name/cobotta_pro_900/cobotta_pro_900/cobotta_pro_900.usd”

it will be automatically downloaded

So the problem is with the URDF importer, which makes incorrect USD model, right? I need this URDF importer to import another manipulator, and I got the same problem, only this time there is no “correct” USD model to work with, so do we have any ideas how to make correct USD models out of URDF?

If using version 2022.2.1, the usd created from urdf importer is correct. So the upgrade of the URDF importer from version 2022.2.1 to version 2023.1.1 introduced a bug?

2023 versions of urdf importer introduced some new features. The one that often causes confusion is that there is now an option to use tendons to implement mimic joints. So if you have a mimic joint in your urdf, and previously you treated it like just another independently activated joint and you want the same behavior, then you need to make sure the option to use mimic joints are off (in the importer GUI).

If that’s not your problem, then it would be very helpful to get more details about the bug you are seeing.