550(beta, and final) is unusable on a RTX 4050 and i7-13620H Laptop

Hi, tried everything to fix my issue but nothing worked, when I tried the 550 beta I noticed that when I switched to 240Hz mode(my laptop monitor only supports 60Hz and 240Hz no in-between) the display would become black with rectangular lines showing the desktop(KDE and Sway), or in GNOME the display would duplicate the desktop 4 or 5 times and flicker a lot, I do not know how to explain better, later 550 version didn’t fixed and starting with 550.67 now even at 60Hz it’s not usable… unless I run Sway(Sway let me run at 60Hz but still not at 240Hz), reverting to 545 fixes all my issues but I can’t stay on 545 forever…

Specs of my laptop :
CPU : Intel Core i7-13620H 10C/16T 4.7GHz.
RAM : 64GB DDR5 4800MHz.
GPU : Nvidia GeForce RTX 4050 Laptop GPU 6GB, Intel iGPU disabled by the Hardware Mux Switch.
OS : openSUSE Tumbleweed with Linux 6.8.1(happens on all linux distributions).

nvidia-drm.modeset=1 is enabled.
Running with MSHybrid is worse as it’s a black screen because the DE start itself on the dGPU, and I do not want to use Hybrid Graphics mode.

Here is a screenshot of what’s happening.

Same problem here, my post Bug report for Linux Driver 550.54.14, display error on multi-monitor with different refresh rate after sleep