802.11ac Wifi Hotspot

Hi,
I am trying to create a 802.11n and 802.11ac MIMO WiFi hotspot. Can someone help me in setting up the same?

I have been able to setup 802.11abg WiFi hotspot using the instructions from the post @ https://devtalk.nvidia.com/default/topic/910608/jetson-tx1/setting-up-wifi-access-point-on-tx1/

Hi SagarGaonkar,

I am checking the issue now. Please wait for reply.

Thanks,
Wayne

Hi SagarGaonkar,

What hostap config are you using? Could you paste it or send as a private message?

On my side, I could have 80211n with default config.

Hi WayneWWW,

Please find below the contents of the hostapd.conf file.


interface=wlan0
ssid=Tegra-WLAN
hw_mode=g
channel=3
wpa=2
wpa_passphrase=1234567890
wpa_key_mgmt=WPA-PSK

driver=nl80211
country_code=US # nothing worked until I set country_code to US
ieee80211d=1
#hw_mode=g
#channel=48 # select a suitable 2.4GHz or 5GHz channel from “iw list” (in the 5ghz band I could only make channels 36, 40, 44, 48 work even though more are listed)
wmm_enabled=1
ieee80211n=1
ieee80211ac=1


Hi SagarGaonkar

Please try this config which should work 11N.

interface=wlan0
driver=nl80211
hw_mode=a
channel=36
ieee80211n=1
ssid=WLAN-test
auth_algs=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=12345678
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0

Hi WayneWWW,

Thanks for your quick response. I am able to get 802.11n to work with the config you gave!

However, I am still unable to get 802.11ac to work. I tried enabling 802.11ac by adding below line but that did not help,
ieee80211ac=1

Any ideas to get this to work?

Does this help?

interface=wlan0
driver=nl80211
hw_mode=a
channel=36
ieee80211ac=1
ssid=WLAN-TEST
auth_algs=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=12345678
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0

This does not seem to help.
I see that the AP is still ‘802.11abgn’

I get following when I run: iwconfig
wlan0 IEEE 802.11abgn Mode:Master Tx-Power=31 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

SagarGaonkar,

Please use iw list to see which channel is supported.

On my side, my 80211ac can work on channel 149.

Hi SagarGaonkar,

Have you managed to get 802.11ac to work?
Any result can be shared or further assistance required?

Thanks

Hi, I’m having the same trouble as SagarGaonkar. When I run

iw list

I get the following for the Band 2 frequencies:

Frequencies:
			* 5180 MHz [36] (20.0 dBm)
			* 5200 MHz [40] (20.0 dBm)
			* 5220 MHz [44] (20.0 dBm)
			* 5240 MHz [48] (20.0 dBm)
			* 5260 MHz [52] (20.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 128 sec)
			* 5280 MHz [56] (20.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 128 sec)
			* 5300 MHz [60] (20.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 128 sec)
			* 5320 MHz [64] (20.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 128 sec)

So, channel 149 is not listed. If I try to run hostapd with channel 149 in hostapd.conf, it won’t work and I get:

wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
wlan0: IEEE 802.11 Configured channel (149) not found from the channel list of current mode (2) IEEE 802.11a
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-3)
wlan0: interface state COUNTRY_UPDATE->DISABLED
wlan0: AP-DISABLED 
wlan0: Unable to setup interface.
wlan0: interface state DISABLED->DISABLED
wlan0: AP-DISABLED 
hostapd_free_hapd_data: Interface wlan0 wasn't started
nl80211: deinit ifname=wlan0 disabled_11b_rates=0

I have also tried using channel 42 or 58 (as shown in the image posted by dusty_nv), but same thing happens. The thing is, those channels are not listed in iw list, and I don’t know how to enable them. Any ideas?