“not a valid win32 application" in CUDA C++

I have a computer with CPU, xeon5650 and GPU Quadro4000. The system is windows 7 64 bit.
visual studio2010 was installed before. Following the intrudction, i installed CUDA toolkit, CUDA SDK, as well as
Fortran and C++ compiler from internet (free 15 day trial). I can creat .exe file in using CUDA C++ sucesssfully.
But when i run the exe file, it shows “not a valid win32 application”.
One of my friends suggested me to changge the flatform from win32 to x64, it still does’t work.
I also tried to reinstall the GPU driver as some people suggested and failed.
There is no problem when i using CUDA fortran.
Should be noticed that when i using CUDA Fortran, it shows the remaining time of the licence.
But When CUDA C++ is used, so such information.
Any body know this problem?

PGI Visual Fortran is a Fortran 2003 compiler with a Visual Studio Shell.

Within a PVF project, there is no C code or C++ that can be compiled.

Visual C++ is the C/C++ compiler for Visual Studio, and PVF coexists
with VC++ - you can have a C++ project and PVF project under a common
Solution, but you cannot have C/C++ sources in a PVF project, or Fortran
sources in a VC++ project.

PVF does handle CUDA Fortran and Fortran Accelerator directives, and
soon the OpenACC directives in fortran.

The command line compilers (aka Win64) do provide C and C++ compilers
that handle the Accelerator and OpenACC directives, on Windows.

I hope that clarifies the issue.