nvcc.exe is not a valid win32 application


I have started using cuda and compiling using visual studio 13 and cuda toolkit 7.5.
I had an issue when trying to compile simple files so I tried on the cmd prompt. I did change the Path environment variable to include the path to cl.exe.
Since then, I keep getting the error message nvcc.exe is not a valid win32 application even when trying to build it through VS13.
I have remove the path to cl.exe rom the Path environment variable and restarted the computer but I still get the same error message. (I have also googled this and tried the few solutions proposed)
Is there something else that I can try to do to solve this?

I am having the same problem as you. Were you able to solve it?
If so, could you share your solution?


It is probably happening due top the presence of incompatible CUDA toolkit version in your PC or may be there is some redundancy in the version. Reinstalling all the Nvidia installation and then again reinstalling a single version of CUDA toolkit will help.
In the newest version you have to use nvcc.exe to compile CUDA programs