Error when running nvcc from a custom build tool - VS 2017 15.2 - CUDA 9.0 - Windows 10


In our Windows 10 build environment, where the PATH environment variable is set to a very long list of paths and where the Visual Studio 2017 (Professional, version 15.2) x64 environment is set too, nvcc commands (CUDA 9.0) launched from custom build tool fail with the message: “‘cl.exe’ is not recognized as an internal or external command”.
I’ve tried to use the the -ccbin option to specify the full pat to the cl.exe command: C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.10.25017\bin\HostX64\x64\cl.exe but this didn’t help.
I cannot easily shorten the PATH value. Is there a way to fix this problem
Thank you

Hi Dominique,

I think you would need to direct this to the CUDA forums rather than to the NGC (cloud) forums. might be a good choice.


I’ve just done what you required. Sorry