A2F REST API ExportBlendshapes does not work

Hi there, I am trying to use the REST API to export the ARKIT blendshapes of given track. I am following the tutorial given by official: Rest API — audio2face latest documentation. Basically I did the following steps: Load USD → SetRootPath → setTrack → GetBlendShapeSolvers → ExportBlendshapes. Everything is fine and getting 200 response except last step. It throws 500 internal error and looks very confusing to me. I am using the USD in the local server: omniverse://localhost/NVIDIA/Assets/Audio2Face/Samples_2023.1/blendshape_solve/mark_solved_arkit.usd. I am using this USD because in GUI I can simply export the bs json file by clicking one export button. Here is the log, and in console of A2F headless server it also keeps saying cannot find a prim node on a certain model. I tried the GetInstance, and this is what I got : /World/audio2face/CoreFullface
kit_20230824_150519.log (316.9 KB)

@RogerBR Could you please take a look at this?

Hi @wanzhang

From the log file, it seems that your file is not loading properly as it cannot load a payload for mark_bs_arkit.usd

kit_20230824_150519.log line 1640

2023-08-24 22:05:50 [31,493ms] [Warning] [omni.usd] Warning (secondary thread): in _ReportErrors at line 2890 of W:\ac88d7d902b57417\USD\pxr\usd\usd\stage.cpp – In </World/mark_bs_arkit>: Could not open asset @C:/Users/wanzhang/Downloads/mark_bs_arkit.usd@ for payload introduced by @C:/Users/wanzhang/Downloads/mark_solved_arkit.usd@****</World/mark_bs_arkit>. (instantiating stage on stage @C:/Users/wanzhang/Downloads/mark_solved_arkit.usd@ <000002F2F9C75210>)

This usd file references two other usd,
You downloaded the file to your Downloads folder but you need to download the reference files as well and place them in the correct relative path

Then you can verify that everything is working correctly by opening in the App UI version.

An alternative is loading the file directly from the nucleus server by specifying a file from omniverse. Make sure to use the explicit server address ( ie. rather than localhost);

in my case :

if you are not sure, you can always get the exact server URL from a file from the Nucleus tab on the launcher :

Hope that helps
let us know otherwise !

Yes, the problem is solved!! thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.