Audio2Face export as USD works but Export as JSON fails to start

Do you have recommendation what I should try to do next?

Everything else seems to function, but export of blendshape wighs or skeletal animation fails to start. Log text is here.

Traceback (most recent call last):\n File “d:\program files\omniverse\library\audio2face-2021.3.3\exts\omni.audio2face.tool\omni\audio2face\tool\scripts\utils.py”, line 30, in wrapper\n return await func(*args, **kwargs)\n File “d:\program files\omniverse\library\audio2face-2021.3.3\exts\omni.audio2face.tool\omni\audio2face\tool\scripts\exporter.py”, line 1129, in _run_export_blendshape_weights_json_async\n animationPath = skeletonPrim.GetRelationship(“skel:animationSource”).GetTargets()[0]\nIndexError: list index out of range\n"}}
{“specversion”:“1.0”,“id”:“4762fa8b-ab52-4e9e-6657-03e9f2989cf1”,“type”:“omni.kit.logging.message”,“source”:“CUT,“data”:{“level”:“error”,“fileName”:“d:\program files\omniverse\library\audio2face-2021.3.3\exts\omni.audio2face.tool\omni\audio2face\tool\scripts\utils.py”,“functionName”:“log_error”,“lineNumber”:19,“threadId”:6528,“processId”:11684,“timestamp”:5456714710200,“message”:”[omni.audio2face.tool] Exception when async ‘<function Exporter._run_export_blendshape_weights_json_async at 0x000001587F7C2D38>’"}}
{“specversion”:“1.0”,“id”:“4762fa8c-ab52-4e9e-6657-03e9f2989cf1”,“type”:“omni.kit.logging.message”,“source”:CUT

I am using Windows 10, A2F 3.3, and the model is standard Character Creator CC3+, using the latest USD plugin, exported with A2F support.

Best regards,

Risto

ps. I have now tried it with two separate PC:s, taking separate steps. The other experiment (Windows 11) yielded similar failyre in exactly the same spot. Is this caused by my iClone CC3+ character?

Hi @risto, from your message, I guess your skeleton prim is not connected to a skelAnimation prim, is ‘bs_anim’ connected to your skeleton prim? Is your blendshape model animated by following the character-transferred model?

If you screen capture the omnigraph editor connection images or the workflow video, it will be easier to see what causes this error. Thanks.

1 Like

Thank you - this contains too much and misses some I guess. I need to learn to read these. But here is:

This is cleaner but still same result. What am I missing?

this image doesn’t help, sorry.
Instead, can you screenshot this view and see if you have proper skel:animationSource from your Skeleton prim (RistoN…)?
image

image

1 Like

Thank you! I guess I am missing the joints and there might be something wrong with the way I produced the USD for A2F from Character Creator. I will try and do that again.

Solved - thank you @yseol ! For some reason I did not have “skel:animation source” -attribute. I added it to the property-page of the skeleton by selecting add, skel, binding API. Seems I missed the the binding API for some reason. In my setup (two different machines, it is left out by default. But now the JSON export started ok. Would not have found this without your help.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.