Acer Nitro AMD vs NVIDIA 1650Ti no HDMI visible, driver does not work

Hi

Running Linux Mint 20
Tried installing the automatic 440 driver , manually 450 and now automatic 450 after adding the Ubuntu PPA.
Unfortunately HDMI does not work, it’s not seen by the system.
The driver is installed but X is not using it.

Can you please post a comprehensive install instruction for me?
All the posts are so scattered it’s counterproductive to try them as they are for different setups.

$ nvidia-settings

ERROR: Unable to load info from any available system

(nvidia-settings:5219): GLib-GObject-CRITICAL **: 02:30:16.708: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 02:30:16.711: PRIME: No offloading required. Abort
** Message: 02:30:16.711: PRIME: is it supported? no

System: Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 info: plank
wm: muffin 4.6.3 dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine: Type: Laptop System: Acer product: Nitro AN515-44 v: V1.01 serial:
Mobo: RO model: Stonic_RNS v: V1.01 serial: UEFI: Insyde v: 1.01 date: 04/16/2020
Battery: ID-1: BAT1 charge: 58.2 Wh condition: 58.2/57.5 Wh (101%) volts: 17.4/15.4 model: LGC AP18E8M type: Li-ion
serial: status: Unknown
CPU: Topology: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71862
Speed: 3251 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 2454 2: 3134 3: 1591 4: 1608 5: 2813
6: 3216 7: 1756 8: 2695 9: 1579 10: 2608 11: 1603 12: 1619
Graphics: Device-1: NVIDIA vendor: Acer Incorporated ALI driver: nvidia v: 440.100 bus ID: 01:00.0 chip ID: 10de:1f95
Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Acer Incorporated ALI driver: N/A bus ID: 05:00.0
chip ID: 1002:1636
Display: x11 server: X.Org 1.20.8 driver: ati,fbdev unloaded: modesetting,nouveau,nvidia,radeon,vesa
resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8 compat-v: 3.1 direct render: Yes

±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.100 Driver Version: 440.100 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 165… Off | 00000000:01:00.0 Off | N/A |
| N/A 37C P0 3W / N/A | 0MiB / 3911MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

Any help is greatly appreciated.

Ok so after adding the ubuntu graphics ppa and installing the 450 driver nvidia-smi shows x running on the laptop display but still there is not hdmi output.
Can someone help me with xrandr config please?

SOLVED IT

Did a vanilla install of Ubuntu 20.
Updtate, upgrade
Install ukuu or other way of getting the latest kernel.
I went for the latest 5.8.3 kernel.
Then add the graphics ppa
Install the 450 (shows as open source)driver via driver manager (correct for the 1650Ti , 1650 is 440 driver)
Check that prime status shows nvidia
Modify /usr/share/X11/xorg.conf.d/10-nvidia.conf

add
Option “PrimaryGPU” “yes”

I also disabled wayland as a tip from another post I found so the display runs in X.
and it worked.

Kernel works fine with the AMD board with no parameters, but I have IOMMU disabled in BIOS, apparently it should work now with 5.8 so maybe going to try after playing a bit more.

Many thanks for your help.