Activation of network connection failed/Unable to connect to device via ssh

That output is correct. “lsusb” won’t see anything different for the “:0955” manufacturer regardless of it being in recovery mode or fully booted, but the presence of this in combination with the address confirms that not only did the Jetson fully boot, the network is in fact available.

I may be repeating some information from before, but I want to make sure I don’t skip anything. With those two above conditions met, can you log in locally to the Jetson? Serial console or actual monitor will work. I am interested in testing if the account you use has been set up.

From the PC, you should be able to “ping”. If not, then from the PC, what is the output of the “route” command? We know the USB is there, and we know the address was assigned. If software cannot reach that address, then we have to assume firewall or route (route is far more likely unless you are working in a corporate environment).

Once you can ping, and once you can log in locally at the Xavier, then we need to verify the combination works: The ssh login to that account.

If ssh login to that account works, then anything which stops SDK Manager/JetPack has to be something specific to the JetPack software and not to the route between PC and Xavier.

Side note to emphasize: During the extra software install the host PC must have access to the internet. At some point during the process the Jetson will probably also want access to the internet, e.g., for updates.

Oh I see what you are saying.

And no worries, I would prefer to have extra clarification and I appreciate all the help you are providing me!

I don’t believe I’ve ever reached the point where I have successfully logged into the Jetson. Is the problem that I need a monitor that is hooked up to an HDMI cable? I have tried running sdk manager with two PCs - one PC installing SDK manager and the other signed into Ubuntu and connected by HDMI. Is this the problem?

I am able to ping This is what I see:
PING ( 56(84) bytes of data.

This is the output of the “route” command:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default _gateway UG 600 0 0 wlo1 U 600 0 0 wlo1
link-local U 1000 0 0 wlo1

Unfortunately my main problem is following the step after flashing the Xavier. After this step when I am most likely supposed to log into Jetson, I don’t see a configuration wizard and if I press continue or move onto the next step it just says “Cannot connect to device via ssh.”

Since both the host PC and Jetson run Ubuntu I am not certain if I am reading correctly on which of the two systems had HDMI on them, but both should have monitors during flash (and the Jetson monitor should be HDMI).

Therefore, yes, you do need an HDMI monitor connected to the Jetson. From what you said I’m not sure if during flash you did or did not have both connected via HDMI. The monitor connected will allow first login to the Jetson upon first boot after flash; meanwhile, the SDKM waits, and then once login occurs to the Jetson via HDMI/keyboard, SDKM can continue (the login via HDMI monitor on the Jetson creates the account SDKM waits for).

There have been some people with issues where even with HDMI connected to the Jetson during flash something went wrong and first boot login did not occur over that monitor, but mostly it should “just work” if you have HDMI on the Jetson during the flash step and first boot. Most issues with this were because of either a non-HDMI monitor (which does not support EDID auto configuration), or else because the monitor simply had specs the driver did not support (odd resolutions).

Have you been using a monitor on the Jetson during flash, and tried to log in on that after it reboots upon flash completion? The SDKM will continue running (but flash will be complete and optional software package additions will be next) and wait for you to do the first boot login.

Gotcha. I had been using two PC laptops and one was running the sdkmanager while connected to the Xavier via USB and the other laptop was connected to Xavier via HDMI. However, nothing would happen on that laptop it would only show the Ubuntu home screen desktop and this is what I am having trouble with. I have been using a laptop for the jetson side, is this the problem? Do I need a monitor specifically? I apologize if I am confusing you in any way. Let me know how I can clarify my setup, thanks!

Nevermind I see the configuration wizard now! Problem solved, thank you for all your help!

Glad it worked. Explaining below anyway since someone may find it useful…

I’m not sure how you would connect a laptop and the Xavier by HDMI. If that laptop has an HDMI input connector and displays video as if it is a monitor or KVM (which I’ve never seen before), then this would probably fail. If so, then the EDID may be unusual and not supported.

You do specifically need a monitor on the Jetson. The HDMI cable has a wire which allows the video card to query specifications, and unless those specifications are found (impossible for some types of video which don’t support EDID), then there is no possibility of success. Additionally, some of the less common video monitor formats (such as from a specialty display) will not work with the driver on the Xavier (only modes pre-programmed are accepted, and there are a lot of small touch screen modes which may not be pre-programmed).