Add partition to Jetson Nano eMMC

Hello,

I am trying to add a partition (2GB) to the jetson nano’s eMMC.
According to information that I found on the forum I need to modify
file flash_l4t_t210_emmc_p3448.xml, which contains a definition of the partition table.

After code:

      <partition name="APP" type="data">
          <allocation_policy> sequential </allocation_policy>
          <filesystem_type> basic </filesystem_type>
          <size> APPSIZE </size>
          <allocation_attribute> 8 </allocation_attribute>
          <unique_guid> APPUUID </unique_guid>
          <filename> APPFILE </filename>
          <description> **Required.** Contains the rootfs. This partition must be defined after
            `primary_GPT` so it can be accessed as the fixed known special device
            `/dev/mmcblk0p1`. </description>
      </partition>

I added partition definition:

      <partition name="USERDATA" type="data">
          <allocation_policy> sequential </allocation_policy>
          <filesystem_type> basic </filesystem_type>
          <size> 2147483648 </size>
          <allocation_attribute> 8 </allocation_attribute>            
          <description> User data </description>
      </partition>

but during flashing I get the error:
Partition USERDATA cannot fit to storage device, total sectors 30777344, current LBA 33554466

I tried to modify the size of the APP partition, that the size of both USERDATA and APP is around 14.7 GB, but flashing stops after writing the APP partition.
Can anyone tell me how to create a partition of the size 2Gb?

Sorry for the late response, is this still an issue to support? Thanks

I temporarily solved the problem by creating a partition of the size 170 MB to save log files, but it would be nice to know how to make a bigger one and where the problem lies.

hello GrzegorzS,

please check p3448-0000.conf.common, you should also reduce the ROOTFSSIZE settings.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.