after i2cset test, nano can't boot

Did you replace the nvtboot.bin and nvtboot_recovery.bin?

Hi WayneWWW,

Yes, but nano still cannot flash and boot as I posted https://devtalk.nvidia.com/default/topic/1056786/-eeprom-nano-cannot-boot/

Could you share the latest log , and the steps you update nvtboot + flash?

Is the log in topic 1056786 after the update of nvtboot or not?

Please note that I have a wrong patch in previous comment, you must use the latest tarball.

The log is after doing #34, #35, #40.
I set Nano to RCM and used the command “sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1” to flash.

Yes, I want to know which file and what have you changed.

I tried to use a clear Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2 just now. The result did not change.

Step 1: uncompress Jetson-Nano-Tegra210_Linux_R32.1.0_aarch64.tbz2
Step 2: uncompress Jetson-Nano-Tegra_Linux_Sample-Root-Filesystem_R32.1.0_aarch64.tbz2
Step 3: run “sudo ./apply_binaries.sh”
Step 4: uncompress nvtboot.tar.gz downloaded from #40 and put nvtboot.bin to Linux_for_Tegra/bootloader/t210ref, nvtboot_recovery.bin to Linux_for_Tegra/bootloader


Step 5: modify jetson-nano-qspi-sd.conf

Step 6: set Nano to RCM

Step 7: use command “sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1” to flash

Just a test. Could you put this to the package downloaded from jetpack instead of using the tarball from download center?

Putting this to the package downloaded from jetpack is still useless!
help~~~

Do you meet same error even after using jetpack?

I mean do you hit same error as

[   3.0116 ] Sending ebt
[   3.0772 ]

Also, could you see any log on UART during flash?

Yes, the same error as the previous test.

UART log

0155.013] Enabled early print
[0155.016] [TegraBoot] (version 00.00.2018.01-l4t-32ed9048)
[0155.021] Processing in recovery mode
[0155.025] A02 Bootrom Patch rev = 1023
[0155.028] Power-up reason: pmc por
[0155.032] Established communication link with host
[0156.166] Odmdata from BCT: 0x00094000
[0156.170] DebugPort= 0x3
[0156.222] EEPROM CRC failed. Calculated crc=0x35 CRC stored = 0x9d
[0156.227] WARNING: Verifying Eeprom failed
[0156.232] Reading Board-ID for Board-Type-1 unsuccessful
[0156.237] BoardId read from EEPROM/NCT: 0
[0156.241] Unsupported Platform 0
[0156.244] Downloaded BCT successfully

Could you check the board id on your sticker or the print on your board?

Where can I find what you said?

The board should have some stickers on it and there are some numbers when you flip over the carrier board.

945-13450-0000-000
S/N: 0421619068092

There should be some text printed on the board. Could you just take a photo of it?

Thanks.

I just notice there is also a sticker/number on the module. If you don’t see any sticker on it, you may need to remove the module from the baseboard. Please also take a picture too.

Would you mind sharing what sdcard you are using ? Is there any other peripheral on your device?

I will share a new binary for you to test later. Thanks.