AGX Orin setup Riva & Docker

I’m new to Nvidia devices. I have a Jetson AGX Orin dev kit. Installing Ubuntu was easy enough, but I’m having problems setting up the dev environment.

I installed JetPack:
sudo apt update
sudo apt dist-upgrade
sudo reboot
sudo apt install nvidia-jetpack

The SDK I need to run is Riva. I’ve downloaded the Riva files. When I run riva_init.sh, I get errors stating docker is missing.

I’ve tried installing docker using the deployment guide, but when I run the command:
sudo apt-get install -y docker-ce docker-ce-cli containerd.io
I get the following errors:

Package docker-ce is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
docker-ce-cli:amd64
E: Package ‘docker-ce’ has no installation candidate
E: Unable to locate package docker-ce-cli
E: Unable to locate package containerd.io
E: Couldn’t find any package by glob ‘containerd.io
E: Couldn’t find any package by regex ‘containerd.io

Any help on the proper steps to get Riva and Docker properly setup and running would be greatly appreciated.

I’m not familiarwith Riva SDK, will forward this issue to internal team to have suggestions.