Jetson Orin Nano Dev kit issue running Riva

Trying to run Riva examples on Jetson Orin Nano Dev kit but cant get models to load.
The Docker container seems to have installed properly but when I run this;

sudo bash

Here is result.

Hi @adventuredaisy,

We don’t have experience with Riva SDK, suggest to post your issue at Riva forum to get the support.
See Latest Deep Learning (Training & Inference)/Riva topics - NVIDIA Developer Forums

I tried this too. First, make sure that you’re running Riva 2.10.

I have not been able to get it to run, but there is at least one obvious problem. The docker container does not have the curl utility installed. The startup script uses curl to check to see if the Riva server is running. This ends up bypassing the Riva server startup; everything else after that is unhappy.

I saved a new version of the image with curl installed. While the startup seemed much happier in that the models were being properly loaded, it still killed the job before everything was finished.

I’m not quite sure why that is, but the preview build of the Jetson Orin Nano software could be one of the reasons. Maybe on the production release everything will work as expected after the Riva curl issue gets fixed.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.