All video recording apps are blurry and slow

My videos are full of lag and are blurry when I try to record myself. It effects all the recording programs from cheese to obs. For some reason Google Meet is slightly better but still suffers the lag at times. Additionally, external monitors don’t work as they are purple with lines on them, never mirroring or extending my environment.

Laptop specs:
Ubuntu 20.04
16gb ram AMD
ryzen 7
geforce gtx 1660 ti mobile
1.3tb of combined hdd and ssd space

Attempted fixed and misc info:
I have tried installing different drives but nothing has worked. I have also noticed that my Nvidia X Server Settings program doesn’t work. It opens to a small 2 inch rectangle with nothing to view. It only has the option to quit. I have tried multiple monitors but none of them have worked. When I reboot with an external monitor plugged in the external monitor works until I log in, at which point it gets lines all over it and shows nothing.

Still having issues and not having any luck finding a solution. Any feedback or suggestions are welcome.

Just an update. I have tried many solutions such as uninstalling and reinstalling Nvidia drivers. Most of that has made my laptop unusable as they failed to work and with no graphics drivers my laptop won’t run properly.

I got to the point in trying to reinstall drivers manually that my entire laptop broke. It was a result of “successful” driver installations which didn’t work but did succeed in shutting off all available drivers. I ended up reinstalling the OS which again is Linux Ubuntu 20.04.

Hi ZeredRavix,

I saw your reply to my post. I’ve looked into your own issue, there are some similarities with mine. It looks like you have a driver problem. If the Nv Settings app doesn’t show up, it might be an issue with the Nv driver.

To check which driver is loaded, you can run:
$ inxi -Gx

Here is my example:
Device-1: NVIDIA driver: nouveau v: kernel bus ID: 0a:00.0
Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau
FAILED: nvidia unloaded: fbdev,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8
direct render: Yes

One can see the driver which is loaded is nouveau. “nouveau” is the Xorg free driver, provided by default with Linux. In a correct situation you should have:
driver: nvidia
unloaded: nouveau and others

So, knowing if you have a broken driver is already a good start to orient your searches. I cannot tell you more, I’m stuck myself, with a problem I don’t understand…
Best of luck, 5circles

1 Like