Anaconda env: "No module named '_carb'" error

Continuing the discussion from [Using my own anaconda env] ModuleNotFoundError: No module named 'carb._carb':

Hi, I am using Isaac Sim with the conda environment, without any change from default.
I found that running a standalone script from out of the Isaac Sim installed directory causes such an error:

(Isaac-sim 2023.1.0 dir)/kit/kernel/py/carb/", line 30, in
from _carb import *
ModuleNotFoundError: No module named ‘_carb’

Of course, I sourced the
By the way, the error does not come out when I run the standalone code when the terminal directory is inside of the Isaac Sim directory. (e.g. at (Isaac Sim dir), $python ~/Documents/

I think someone else can easily fix this problem by adjusting bash files, but I am a beginner in this area, so would like to ask how to fix this error.
I would appreciate any helpful comments.

Hi @user15623 - Can you confirm if you are using this document when creating Conda environment?

I followed the instructions, but did not remove the 2022.2.1 conda environment (I simply changed its name). I solved the issue by uninstalling the 2022.2.1 version along with its associated conda environment, and then installing only the 2023.1.0 version. I guess maintaining multiple Isaac Sim conda environments may cause this kind of error.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.