Android can not connect WiFi hotspot after disconnected

Hi everyone. I encountered a problem setting Jetson Xavier as a WiFi Hotspot.

I am using Jetson Xavier, with Jetpack 4.3.0.

And the WiFi module is Intel 8265.NGWMG.

So I did

  1. Turn on Wi-Fi hotspot in system setting.

  2. Create new internet connection for the turned-on Wi-Fi hotspot.

  • Keep disconnect and connect (in Ubuntu Network).
  • Turned-off power saving mode for Wi-Fi
  • Disconnection and Connection problem solved (in Ubuntu Network)
  1. Wi-Fi could not be seen in Android.
  • Change the Ad-hoc mode to hotspot mode in the created Wi-Fi Hotspot in network configuration.
  1. Wi-Fi hotspot could be found in the Android.

  2. Successfully connected the Wi-Fi with Android once with password.

  3. Disconnect it again.

  4. The Wi-Fi could still be searched with the Android but I was not able to connect to the Wi-Fi Hotspot again.

Not able connect to the Jetson Xavier Wi-Fi hotspot again with the following trials:

  1. Reset Network Manager.

  2. Remove the network in the network configuration and create a new one.

  3. Turned off the system, removed the modules, turned on the system. Reset Network Manager and then reinstalled the modules after turning off.

  4. Confirmed to be the correct password.
    Occasionally, android would say I gave wrong password. Disconnected the Wi-Fi and recreate a new one after password change. Still useless.

  5. Remove the password. The Wi-Fi is there but I could not connect to it not matter how many times I clicked.

Also, 802.11/ac could not be found in the Ubuntu.

Thanks in advance.

Do you have other device that can do this test instead of the Android device?

Thank you for your reply.

I used “create network connection…” and opened created hotspot, the problem was solved.