Application Error: Could not populate 3rd party credentials in the Workbench Service

Submission Type
Bug or Error

Workbench Version
Desktop App v0.50.17

Host Machine operating system and location
Local Windows 11

main.log (192.3 KB)
nvwb.log (1.6 KB)

The Installation process gets an “Application Error” and says to restart the application or reinstall. if it persists to contact support.
I re-run the application, it runs and open up to Environment Selection with options to select a local environment or connect to remote.
When i click the Local environment i get an error that tells me to look at nvwb logs.
The nvwb logs says “credential-manager.exe: no such file or directory”

The path its trying to access is wrong. the logs show
“/mnt/c/Users/badeed/AppData/Local/NVIDIA Corporation/AI Workbench/credential-manager.exe”
but the correct path is
“/mnt/c/Users/badee/AppData/Local/NVIDIA Corporation/AI Workbench/credential-manager.exe”
My windows username is “badeed” but my folder is “badee”

USERNAME: ‘badeed’,
USERPROFILE: ‘C:\Users\badee’,

i was able to find a work around by running:

mklink /D C:\Users\badeed C:\Users\badee

Which worked for me and got me through the installation process
I thought id report the issue.

Thank you for reporting this. We are working on being more robust to changes between user names and the associated folders.

This is a good workaround and thank you.

I am having same issue.

{“level”:“error”,“error”:“fork/exec /mnt/c/Users/thisisjaymehta/AppData/Local/NVIDIA Corporation/AI Workbench/credential-manager.exe: no such file or directory”,“isWrapped”:false,“isInteractive”:false,“engine”:“json”,“detail”:“detail”,“time”:“2024-06-09T16:20:51+05:30”,“message”:“Could not populate 3rd party credentials in the Workbench Service”}

This is wrong path. Correct path should be /mnt/c/Users/jayme/AppData/Local/NVIDIA Corporation/AI Workbench/credential-manager.exe

did you change your username at some point?

No, Windows set up on windows 11 only allows 5 character folder names if made using Microsoft Account.

So my set up email was badeed@domain.com
The folder became “badee” the User still is “badeed”

It’s a Windows set up thing/issue. Which is extremely annoying. I spent long time trying to making 6 characters by default all workarounds had some sort of flaw/issue. So I gave up.

Ok. Thank you very much for persisting.

We are escalating this.

We will also see if there is a workaround for you.

This workaround worked for what is needed

mklink /D C:\Users\badeed C:\Users\badee

I was just explaining why the name is different from the username

1 Like

Got it and now I remember you posted this solution before.

Thank you!

Can you try the workaround used here Application Error: Could not populate 3rd party credentials in the Workbench Service - #7 by bad_eed?

I did, and the given error is gone. Thank’s @bad_eed .

But now another error is coming:

{“level”:“error”,“isWrapped”:false,“isInteractive”:false,“engine”:“json”,“detail”:“detail”,“time”:“2024-06-12T12:20:24+05:30”,“message”:“Warning: Git author configuration incomplete!”}

I have git installed and configured as well.

ok. how far are you getting through the install?

remember that the git config in question is in the WSL distro, NVIDIA-Workbench.

it is also managed by Workbench to some extent.

  • You have to right click the AI workbench in the toolbar/taskbar

  • Click settings/options

  • Click the integration page should be there fill it up !

1 Like

@bad_eed thanks a lot, it worked and now I am able to create a new project.

1 Like

We should have this corrected in the next release.

Thanks a lot for persisting on this and bringing it to our attention!

You were going to go out of your way to help.
I saw an email I replied :) least I can do.

Thank you

1 Like