Asus tuf fx505dt - amd ryzen 5 - GeForce GTX1650 Mobile - Ubuntu 16.04

Hello
So I have an amd/nvidia build and I have trouble making the nvidia gpu to work. As I can see a lot of people face issues although none of the solutions proposed fix my problem. Right now I installed the nvidia drivers following this guide for Ubuntu 16.04 https://www.tensorflow.org/install/gpu

After installing the driver (418 currently) I am stuck in a login loop. I have tried many versions (430,440,450) from ppa and the same problem still occurs. I only have access to tty.

I only want to use the nvidia gpu I do not care about the embedded one so I did not download any drivers for it.

Some info that could be useful:
nvidia-smi output

I have installed nvidia prime-select and selected nvidia. Tthe prime-select query output is nvidia.

From the solutions I found while browsing the forum I have changed the 10-amdgpu.conf file to :
Section “OutputClass”
Identifier “AMDgpu”
MatchDriver “amdgpu”
Driver “modesetting”
EndSection

I also tried the option Option “PrimaryGPU” “Yes” for the nvidia configuration file although that results in a black screen and a parsing error in the bug report so I removed it.

This is my current bug report I tried to look it and see if I can make sense out of it but this is beyond my knowledge.
http://paste.ubuntu.com/p/85Rydw6Pfq/

Let me know if any additional info is required.

That won’t really work with 16.04 since this is a hybrid graphics notebook with recent AMD igpu which needs a recent kernel to work. Without the igpu, the secondary nvidia gpu can’t do anything.
Please install at least Ubuntu 18.04, upgrade HWE stack to get a recent kernel, install nvidia driver in Ubuntu’s Software&Updates application, then follow this on how to enable prime on amd/nvidia combos:
https://forums.developer.nvidia.com/t/nvidia-xconfig-doesnt-do-what-i-want-it-to-nor-does-nvidia-settings/107883/7?u=generix

1 Like

Thank you so much for the fast response! I was afraid that I wouldn’t be able to use Ubuntu 16. I will try your solution after work and will get back to you.

Thank you again it worked! Everything works I have driver version 450 and cuda 11.