Authorization flow not allowed - invalid_request

Dear all,
i face an issue when i am trying to install older SDK manager versions <1.8.0.
My OS is Ubuntu 20.04.5 LTS and i want to install the Jetpack version 4.5.1 on my xavier nx, unfortunately when i am trying to log in to the system the message below appears:
Authorization flow not allowed - invalid_request

Any suggestions ?


1 Like


I had just the same problem. Update you sdkmanager with “sdkmanager --checkforupdates”

I hope it helps


Thank you for your reply!
The last days, i have tried to install all the previous versions, unfortunately it supports only the latest 1.9.3 version.
The question is that all my libraries are compatible with 4.5.1 Jetpack version, which requires previous SDK manager.

One can see many of the older releases if starting sdkmanager like this:
sdkmanager --archivedversions
(there are some limitations, but more is available than it looks like; by default sdkmanager only shows the most recent release)

Hello i face the exact same issue i need jetpack 4.5.1 for the Jetson Xavier AGX. I use Ubuntu 18.04 sdkmanager
How to solve this?

Have you started the most recent JetPack 4.x like this?
sdkmanager --archivedversions

1 Like

Dear linuxdev,
thank you for your reply!
I have tried it, but opens the latest version.

It would open the latest version, but for flash targets at the flash stage, it should offer older releases. Are older releases not able to be checked/unchecked at the flash stage?

Dear Linuxdev,
thank you for your reply!
It worked!


1 Like

Thanks a lot this worked for me.

Depending on the OS. I opened it with Ubuntu 18.04 and the last two versions were not checked.

Historically, there was a time somewhere in the L4T R32.x earlier versions, and previous, which did not allow software-based upgrades of L4T releases, and mandated a full flash. It is at that cutoff point (and newer) that JetPack/SDK Manager shows older archived releases. How old of a release are you looking for? If it is that old, then this would be why the oldest of releases do not show up.

Incidentally, this is the list of releases via L4T version or SDKM version (the two are tied together, so either leads to the same web page):

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.