Best Way to Get Software with Rogue Carrier and without Dev Kit

I do not have the dev kit for the AGX Xavier, but I do have a Rogue Carrier attached. I tried to copy and install the packages from the SDK manager to the board manually then updated everything on the board. However, I am not able to get programs that use the packages I installed like DeepStream or VisionWorks to run properly because it says I’m missing files. I also do not have Jetpack installed on the Xavier. Do I even need it? What is the best way to go about go about getting the software with a rogue carrier and not a dev kit? Thank you in advance!

This is probably not a very helpful answer but I would definitely recommend reaching out to Connect Tech regarding this. They have a great customer service team and have been very helpful whenever I had any carrier board related queries.

I believe the process for their carrier boards is usually installing a board support package provided by connect tech and then installing JetPack as usual afterwards. This is how I usually set up new TX2+Orbittys. I haven’t worked with the Rogue so I’m not sure if this has changed recently.

Also not an answer, but if your Xavier is fully booted, then JetPack uses only wired ethernet (via the virtual USB-C ethernet NIC) to perform the software install over ssh. If the booted Xavier has a USB-C on this carrier (I don’t know, I’ve never seen one), and if that USB-C is the one used for a virtual USB NIC, then as you monitor your host PC via “dmesg --follow” you would see the MAC address of the virtual NIC as the USB-C is plugged in to the host PC. If you can ssh to that address (you may need to enable the virtual NIC on the PC), then all software install should work. Related addresses:


Thank you for your suggestions, but unfortunately, I am still stuck. I tried flashing the BSP and then installing JetPack with the SDK manager beta 12 (which was advised by a ConnectTech employee), but the HDMI ports do not work after the flashing. When the HDMI is plugged into the monitor, the monitor just goes into power saving mode. It worked before I did the JetPack installation and after I flashed the BSP. I can’t even ssh yet because I still need to complete the initial configuration.

HDMI is probably a separate issue. Many people assume no video is a failure to boot or an install issue even when it isn’t. Understand that HDMI reads the monitor’s configuration through a DDC wire within the cable…the EDID data. The monitor configuration depends on this, and only modes read through EDID are allowed. Among those modes, only known modes within a preexisting mode pool are accepted. If EDID fails to be read, or if your monitor reports a configuration not within its predefined mode pool, then the HDMI falls back to some other basic mode. If HDMI works with a monitor not supported the correct subset of its modes plus mode pool, then it is because it happened to work with a default fallback mode. Different releases may use different fallback modes.

So the first step is to determine if EDID was read, and to know if the cable is pure HDMI? What do you see from this:

sudo -s
cat `find /sys -name edid`

Also, does anything change if after boot you unplug and replug the HDMI cable? What occurs if you boot without HDMI, and then later attach the cable? FYI, you can use ssh and monitor “dmesg --follows” while doing so, and changes which get logged during cable plug or unplug are useful.